summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:31:40 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:28 +0200
commit0403ace5ce648607eb824ff65c5e234def9f428e (patch)
treeff81196c4da0251a2d01a8b283a9fa83a20c99a4 /games-emulation/fceux/fceux-2.2.3.ebuild
parentgames-emulation/fbzx: Drop old (diff)
downloadgentoo-0403ace5ce648607eb824ff65c5e234def9f428e.tar.gz
gentoo-0403ace5ce648607eb824ff65c5e234def9f428e.tar.bz2
gentoo-0403ace5ce648607eb824ff65c5e234def9f428e.zip
games-emulation/fceux: Version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation/fceux/fceux-2.2.3.ebuild')
-rw-r--r--games-emulation/fceux/fceux-2.2.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-emulation/fceux/fceux-2.2.3.ebuild b/games-emulation/fceux/fceux-2.2.3.ebuild
new file mode 100644
index 000000000000..93ccbe28693f
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit desktop epatch scons-utils
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk logo +lua +opengl"
+
+RDEPEND="
+ lua? ( dev-lang/lua:0 )
+ media-libs/libsdl[opengl?,video]
+ logo? ( media-libs/gd[png] )
+ opengl? ( virtual/opengl )
+ gtk? ( x11-libs/gtk+:3 )
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.2-warnings.patch
+}
+
+src_compile() {
+ escons \
+ GTK=0 \
+ CREATE_AVI=1 \
+ SYSTEM_LUA=1 \
+ SYSTEM_MINIZIP=1 \
+ $(use_scons gtk GTK3) \
+ $(use_scons logo LOGO) \
+ $(use_scons opengl OPENGL) \
+ $(use_scons lua LUA)
+}
+
+src_install() {
+ dobin bin/fceux
+
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+ make_desktop_entry fceux FCEUX
+ doicon fceux.png
+}