summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-01 04:38:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-11-01 05:38:13 -0400
commitf22ebdad15e4a5280799c9314260c2d365c41610 (patch)
treed97e0e3a7e6b26eb30ae718a528095f64922cde0 /games-emulation
parentxfce-base/thunar-volman: Bump to 4.19.0 (diff)
downloadgentoo-f22ebdad15e4a5280799c9314260c2d365c41610.tar.gz
gentoo-f22ebdad15e4a5280799c9314260c2d365c41610.tar.bz2
gentoo-f22ebdad15e4a5280799c9314260c2d365c41610.zip
games-emulation/pcsx2: drop 1.7.5913
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/Manifest1
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.5913.ebuild179
2 files changed, 0 insertions, 180 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index 1197af6b0738..a73abe9f92bc 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1,2 +1 @@
-DIST pcsx2-1.7.5913.tar.gz 15669443 BLAKE2B 1b1e353b544791fb52d9e181e66fcdf0bc7039878a80279b855d05fdab4f1010f45db685d4ab6ae141f497cd72a6e007f583725345a9ef1c9a6d69dc46a77547 SHA512 a8c2e6879527d4864de97ece74aefcbe34093c169a19aafe7558aef872a449be5209209f800ca71b4d259689583f10188b8385439b769688910dc5c3b291c408
DIST pcsx2-2.0.2.tar.gz 16071515 BLAKE2B 328ea302ab2a7f7c4784844005ad4091d3f0b571c80f2a122136cc152fd46d4b1db4541e53ada09fc6cd15ebf37ae494911cadbbc7c57b92b494da355f67fcef SHA512 d442b1c5f9dbd1dca23261c56d0a433771928827b1ff9ebf5bea9cf5c5013defab659e7f0b63f5ce5c6ad856461c00f6ac98498a229300f8d58b9ea0ebf21507
diff --git a/games-emulation/pcsx2/pcsx2-1.7.5913.ebuild b/games-emulation/pcsx2/pcsx2-1.7.5913.ebuild
deleted file mode 100644
index eabda37bc8cf..000000000000
--- a/games-emulation/pcsx2/pcsx2-1.7.5913.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake desktop fcaps flag-o-matic optfeature toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2.git"
-else
- SRC_URI="
- https://github.com/PCSX2/pcsx2/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz
- "
- KEYWORDS="-* amd64"
-fi
-
-DESCRIPTION="PlayStation 2 emulator"
-HOMEPAGE="https://pcsx2.net/"
-
-LICENSE="
- GPL-3+ Apache-2.0 BSD BSD-2 BSD-4 Boost-1.0 CC0-1.0 GPL-2+
- ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain
-"
-SLOT="0"
-IUSE="alsa cpu_flags_x86_sse4_1 +clang jack pulseaudio sndio test vulkan wayland"
-REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
-RESTRICT="!test? ( test )"
-
-# dlopen: libglvnd, qtsvg, shaderc, vulkan-loader, wayland
-COMMON_DEPEND="
- app-arch/lz4:=
- app-arch/zstd:=
- dev-qt/qtbase:6[concurrent,gui,widgets]
- dev-qt/qtsvg:6
- media-libs/freetype
- media-libs/libglvnd[X]
- media-libs/libjpeg-turbo:=
- media-libs/libpng:=
- media-libs/libsdl2[haptic,joystick]
- media-libs/libwebp:=
- media-video/ffmpeg:=
- net-libs/libpcap
- net-misc/curl
- sys-apps/dbus
- sys-libs/zlib:=
- virtual/libudev:=
- x11-libs/libXrandr
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
- pulseaudio? ( media-libs/libpulse )
- sndio? ( media-sound/sndio:= )
- vulkan? (
- media-libs/shaderc
- media-libs/vulkan-loader
- )
- wayland? ( dev-libs/wayland )
-"
-# patches is a optfeature but always pull given PCSX2 complaints if it
-# is missing and it is fairly small (installs a ~1.5MB patches.zip)
-RDEPEND="
- ${COMMON_DEPEND}
- >=games-emulation/pcsx2_patches-0_p20230917
-"
-DEPEND="
- ${COMMON_DEPEND}
- x11-base/xorg-proto
-"
-BDEPEND="
- dev-qt/qttools:6[linguist]
- clang? ( sys-devel/clang:* )
- wayland? (
- dev-util/wayland-scanner
- kde-frameworks/extra-cmake-modules
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.4667-flags.patch
- "${FILESDIR}"/${PN}-1.7.5232-cubeb-automagic.patch
- "${FILESDIR}"/${PN}-1.7.5835-vanilla-shaderc.patch
- "${FILESDIR}"/${PN}-1.7.5855-no-libbacktrace.patch
- "${FILESDIR}"/${PN}-1.7.5835-musl-header.patch
- "${FILESDIR}"/${PN}-1.7.5913-musl-cache.patch
-)
-
-src_prepare() {
- cmake_src_prepare
-
- if [[ ${PV} != 9999 ]]; then
- sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}'"/' \
- -i cmake/Pcsx2Utils.cmake || die
- fi
-
- # relax Qt6 and SDL2 version requirements which often get restricted
- # without a specific need, please report a bug to Gentoo (not upstream)
- # if a still-available older version is really causing issues
- sed -e '/find_package(\(Qt6\|SDL2\)/s/ [0-9.]*//' \
- -i cmake/SearchForStuff.cmake || die
-}
-
-src_configure() {
- # note that upstream only supports clang and ignores gcc issues, e.g.
- # https://github.com/PCSX2/pcsx2/issues/10624#issuecomment-1890326047
- # (CMakeLists.txt also gives a big warning if compiler is not clang)
- if use clang && ! tc-is-clang; then
- local -x CC=${CHOST}-clang CXX=${CHOST}-clang++
- strip-unsupported-flags
- fi
-
- # pthread_attr_setaffinity_np is not supported on musl, may be possible
- # to remove if bundled lzma code is updated like 7zip did (bug #935298)
- use elibc_musl && append-cppflags -DZ7_AFFINITY_DISABLE
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=no
- -DDISABLE_ADVANCE_SIMD=yes
- -DENABLE_TESTS=$(usex test)
- -DUSE_LINKED_FFMPEG=yes
- -DUSE_VTUNE=no
- -DUSE_VULKAN=$(usex vulkan)
-
- # note that upstream hardly support native wayland, may or may not work
- # https://github.com/PCSX2/pcsx2/pull/10179
- -DWAYLAND_API=$(usex wayland)
- # not optional given libX11 is hard-required either way and upstream
- # seemingly has no intention to drop the requirement at the moment
- # https://github.com/PCSX2/pcsx2/issues/11149
- -DX11_API=yes
-
- # bundled cubeb flags, see media-libs/cubeb and cubeb-automagic.patch
- -DCHECK_ALSA=$(usex alsa)
- -DCHECK_JACK=$(usex jack)
- -DCHECK_PULSE=$(usex pulseaudio)
- -DCHECK_SNDIO=$(usex sndio)
- -DLAZY_LOAD_LIBS=no
- )
-
- cmake_src_configure
-}
-
-src_test() {
- cmake_build unittests
-}
-
-src_install() {
- insinto /usr/lib/${PN}
- doins -r "${BUILD_DIR}"/bin/.
-
- fperms +x /usr/lib/${PN}/pcsx2-qt
- dosym -r /usr/lib/${PN}/pcsx2-qt /usr/bin/${PN}
-
- newicon bin/resources/icons/AppIconLarge.png ${PN}.png
- make_desktop_entry ${PN} ${PN^^}
-
- dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,debugger.txt}
-
- use !test || rm "${ED}"/usr/lib/${PN}/*_test || die
-}
-
-pkg_postinst() {
- fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
-
- # calls aplay or gst-play/launch-1.0 as fallback
- # https://github.com/PCSX2/pcsx2/issues/11141
- optfeature "UI sound effects support" \
- media-sound/alsa-utils \
- media-libs/gst-plugins-base:1.0
-
- if [[ ${REPLACING_VERSIONS##* } ]] &&
- ver_test ${REPLACING_VERSIONS##* } -lt 1.7; then
- elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, and is"
- elog "notably now a 64bit build using Qt6. Just-in-case it is recommended"
- elog "to backup configs, save states, and memory cards before using."
- elog
- elog "The executable was also renamed from 'PCSX2' to 'pcsx2'."
- fi
-}