summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:22 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:12 +0000
commitc909bc83e96d909b50264bc4103988830f8f2dbe (patch)
tree93a88d9acbd878cf2aba227027df530dcfb9692c /games-fps/darkplaces
parentgames-arcade/stardork: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-c909bc83e96d909b50264bc4103988830f8f2dbe.tar.gz
gentoo-c909bc83e96d909b50264bc4103988830f8f2dbe.tar.bz2
gentoo-c909bc83e96d909b50264bc4103988830f8f2dbe.zip
games-fps/darkplaces: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/darkplaces')
-rw-r--r--games-fps/darkplaces/darkplaces-20140513-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-fps/darkplaces/darkplaces-20140513-r1.ebuild b/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
index 7ba3bcdb4ce9..c0fafee1498d 100644
--- a/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
+++ b/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -92,7 +92,7 @@ src_prepare() {
# Only additional CFLAGS optimization is the -march flag
local march=$(get-flag -march)
sed -i \
- -e "s:-lasound:$(pkg-config --libs alsa):" \
+ -e "s:-lasound:$($(tc-getPKG_CONFIG) --libs alsa):" \
-e "/^CPUOPTIMIZATIONS/d" \
-e '/^OPTIM_RELEASE/s/=.*/=$(CFLAGS)/' \
-e '/^OPTIM_DEBUG/s/=.*/=$(CFLAGS)/' \