summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/cubetest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/cubetest')
-rw-r--r--games-kids/cubetest/Manifest1
-rw-r--r--games-kids/cubetest/cubetest-0.9.4.ebuild34
-rw-r--r--games-kids/cubetest/files/cubetest-0.9.4-build.patch101
-rw-r--r--games-kids/cubetest/metadata.xml5
4 files changed, 141 insertions, 0 deletions
diff --git a/games-kids/cubetest/Manifest b/games-kids/cubetest/Manifest
new file mode 100644
index 000000000000..64139b6561f2
--- /dev/null
+++ b/games-kids/cubetest/Manifest
@@ -0,0 +1 @@
+DIST cubetest-0.9.4.tar.bz2 764429 SHA256 fa7341a081a4803f26dd95c5ceb998867ed120b2e0ce0a61b758ced37d782521 SHA512 91f1d312ba4cfb08d359ab43347088592977a0d5758baf64a17d62b49d7a53f5b112e16d2a98e3217c6eb06426ef320039d1ae8af8298eb010952473116c916b WHIRLPOOL b004e8d42c2447c484ef524a7f8421cb70f2664207a43135de372e472faf89042018afe435d304c4ecb812b569cddc127437980da3e091bf38031f2cf1391043
diff --git a/games-kids/cubetest/cubetest-0.9.4.ebuild b/games-kids/cubetest/cubetest-0.9.4.ebuild
new file mode 100644
index 000000000000..82214cc8207c
--- /dev/null
+++ b/games-kids/cubetest/cubetest-0.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A program to train your spatial insight"
+HOMEPAGE="http://www.vandenoever.info/software/cubetest/"
+SRC_URI="http://www.vandenoever.info/software/cubetest/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtcore:4[qt3support]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ local i
+
+ epatch "${FILESDIR}"/${P}-build.patch
+ for i in $(find src/ -iname *_moc.cpp) ; do
+ moc ${i/_moc.cpp/.h} -o $i || die
+ done
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-kids/cubetest/files/cubetest-0.9.4-build.patch b/games-kids/cubetest/files/cubetest-0.9.4-build.patch
new file mode 100644
index 000000000000..71411700c336
--- /dev/null
+++ b/games-kids/cubetest/files/cubetest-0.9.4-build.patch
@@ -0,0 +1,101 @@
+diff -ru cubetest-0.9.4.orig/configure cubetest-0.9.4/configure
+--- cubetest-0.9.4.orig/configure 2005-12-05 17:29:43.000000000 -0500
++++ cubetest-0.9.4/configure 2009-09-20 21:23:24.886585972 -0400
+@@ -19741,13 +19741,16 @@
+ if test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"QtGui >= \$QT_REQUIRED_VERSION
++ QtCore >= \$QT_REQUIRED_VERSION
+ Qt3Support >= \$QT_REQUIRED_VERSION\"") >&5
+ ($PKG_CONFIG --exists --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+ pkg_cv_QT_CFLAGS=`$PKG_CONFIG --cflags "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION" 2>/dev/null`
+ else
+ pkg_failed=yes
+@@ -19758,13 +19761,16 @@
+ if test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"QtGui >= \$QT_REQUIRED_VERSION
++ QtCore >= \$QT_REQUIRED_VERSION
+ Qt3Support >= \$QT_REQUIRED_VERSION\"") >&5
+ ($PKG_CONFIG --exists --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+ pkg_cv_QT_LIBS=`$PKG_CONFIG --libs "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION" 2>/dev/null`
+ else
+ pkg_failed=yes
+@@ -19775,6 +19781,7 @@
+
+ if test $pkg_failed = yes; then
+ QT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION"`
+ # Put the nasty error message in config.log where it belongs
+ echo "$QT_PKG_ERRORS" 1>&5
+@@ -19842,6 +19849,7 @@
+
+ fi
+
++ QT_CXXFLAGS="$QT_CFLAGS $QT_CXXFLAGS"
+ { echo "$as_me:$LINENO: Set QT_CXXFLAGS... $QT_CXXFLAGS" >&5
+ echo "$as_me: Set QT_CXXFLAGS... $QT_CXXFLAGS" >&6;}
+ { echo "$as_me:$LINENO: Set QT_LIBS... $QT_LIBS" >&5
+Only in cubetest-0.9.4: configure.orig
+diff -ru cubetest-0.9.4.orig/src/cubetest/cubetest_it.ts cubetest-0.9.4/src/cubetest/cubetest_it.ts
+--- cubetest-0.9.4.orig/src/cubetest/cubetest_it.ts 2005-12-05 14:48:20.000000000 -0500
++++ cubetest-0.9.4/src/cubetest/cubetest_it.ts 2009-09-20 21:23:06.640704967 -0400
+@@ -19,11 +19,11 @@
+ </message>
+ <message>
+ <source>Well done! The correct answer is %1.</source>
+- <translation>Bene! La risposta esatta &egrave; %1.</translation>
++ <translation>Bene! La risposta esatta &#232; %1.</translation>
+ </message>
+ <message>
+ <source>Wrong! The correct answer is %1.</source>
+- <translation>Sbagliato! La risposta esatta &egrave; %1.</translation>
++ <translation>Sbagliato! La risposta esatta &#232; %1.</translation>
+ </message>
+ <message>
+ <source>Next question</source>
+@@ -69,11 +69,11 @@
+ </message>
+ <message>
+ <source>Difficulty </source>
+- <translation>Difficolt&agrave;</translation>
++ <translation>Difficolt&#224;</translation>
+ </message>
+ <message>
+ <source>Can I play Daddy?</source>
+- <translation>Posso giocare, Pap&agrave;?</translation>
++ <translation>Posso giocare, Pap&#224;?</translation>
+ </message>
+ <message>
+ <source>Don&apos;t hurt my brain</source>
+@@ -113,7 +113,7 @@
+ </message>
+ <message>
+ <source>CubeTest is written by Jos van den Oever and released under the General Public License.</source>
+- <translation>CubeTest &egrave; stato scritto da Jos van der Oever ed &egrave; rilasciato con la Licenza Pubblica Generale (GPL) di GNU.</translation>
++ <translation>CubeTest &#232; stato scritto da Jos van der Oever ed &#232; rilasciato con la Licenza Pubblica Generale (GPL) di GNU.</translation>
+ </message>
+ <message>
+ <source>Easy</source>
+@@ -132,4 +132,4 @@
+ <translation>Ostico</translation>
+ </message>
+ </context>
+-</TS>
+\ No newline at end of file
++</TS>
diff --git a/games-kids/cubetest/metadata.xml b/games-kids/cubetest/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-kids/cubetest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>