summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-10-19 09:12:53 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-10-20 12:26:32 +0100
commit37cd0fcfe3d7f32024a7b00096ec3f2f52891e14 (patch)
treeec190164d5dfcf1032171cea112f9c25445be1c2 /games-misc/cowsay/cowsay-3.04.ebuild
parentmedia-fonts/liberation-fonts: drop broken python2 compat (diff)
downloadgentoo-37cd0fcfe3d7f32024a7b00096ec3f2f52891e14.tar.gz
gentoo-37cd0fcfe3d7f32024a7b00096ec3f2f52891e14.tar.bz2
gentoo-37cd0fcfe3d7f32024a7b00096ec3f2f52891e14.zip
games-misc/cowsay: bump to 3.04
Closes: https://bugs.gentoo.org/680466 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13338 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-misc/cowsay/cowsay-3.04.ebuild')
-rw-r--r--games-misc/cowsay/cowsay-3.04.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-misc/cowsay/cowsay-3.04.ebuild b/games-misc/cowsay/cowsay-3.04.ebuild
new file mode 100644
index 000000000000..2186ca0454ba
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.04.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Configurable talking ASCII cow (and other characters)"
+HOMEPAGE="https://github.com/tnalpgge/rank-amateur-cowsay"
+SRC_URI="https://github.com/tnalpgge/rank-amateur-${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc64 ~x86 ~x64-solaris"
+
+RDEPEND=">=dev-lang/perl-5"
+BDEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-tongue.patch"
+ "${FILESDIR}/${P}-mech.patch"
+ "${FILESDIR}/${P}-utf8.patch"
+ "${FILESDIR}/${P}-version.patch" )
+
+S="${WORKDIR}/rank-amateur-${PN}-${P}"
+
+src_prepare() {
+ sed -i \
+ -e "1 c\#!${EPREFIX}/usr/bin/perl"\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:${EPREFIX}/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|${EPREFIX}/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+
+ default
+}
+
+src_compile() {
+ ./install.sh "${D}"
+}
+
+src_install() {
+ dobin cowsay
+ doman cowsay.1
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1 /usr/share/man/man1/cowthink.1
+ insinto /usr/share/${P}
+ doins -r cows
+ einstalldocs
+}