summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/lucidlife
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/lucidlife')
-rw-r--r--games-misc/lucidlife/Manifest1
-rw-r--r--games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch70
-rw-r--r--games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch11
-rw-r--r--games-misc/lucidlife/lucidlife-0.9.2.ebuild39
-rw-r--r--games-misc/lucidlife/metadata.xml10
5 files changed, 131 insertions, 0 deletions
diff --git a/games-misc/lucidlife/Manifest b/games-misc/lucidlife/Manifest
new file mode 100644
index 000000000000..c89c8e9dd8b5
--- /dev/null
+++ b/games-misc/lucidlife/Manifest
@@ -0,0 +1 @@
+DIST lucidlife-0.9.2.tar.gz 1506448 SHA256 7ef3e3a71e771642e2749ccff2adf1c88c9f1798444d6a34665ce528aef58048 SHA512 5184d6a5a2d48b38b2a72edbab6ca4f251547e5c54234792d3821482d39e5fbb2b96ab171544dc3e6843f9976c1dc40935eb3537dcf06c1cb0c717260bd04b01 WHIRLPOOL 41339dacc97fde20d7951f8e51b07b3913ec1155f4b7393b8dfc38ccf1ac58f532f54c339f05f7568bf53d88d2ca25f45611122d781615737b651124feb427b6
diff --git a/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch b/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch
new file mode 100644
index 000000000000..49918b62146a
--- /dev/null
+++ b/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch
@@ -0,0 +1,70 @@
+--- lucidlife-0.9.2/configure.ac
++++ lucidlife-0.9.2/configure.ac
+@@ -23,7 +23,7 @@
+ AC_SUBST(CFLAGS)
+ AC_SUBST(LDFLAGS)
+
+-GNOME_MODULES="[gtk+-2.0 >= 2.6.0 gnome-vfs-2.0 >= 2.0.0]"
++GNOME_MODULES="[gtk+-2.0 >= 2.6.0]"
+ PKG_CHECK_MODULES(GNOME, $GNOME_MODULES)
+ AC_SUBST(GNOME_CFLAGS)
+ AC_SUBST(GNOME_LIBS)
+--- lucidlife-0.9.2/src/lucidlife.c
++++ lucidlife-0.9.2/src/lucidlife.c
+@@ -35,8 +35,6 @@
+
+ #include <gtk/gtk.h>
+ #include <glib.h>
+-#include <libgnomevfs/gnome-vfs-init.h>
+-#include <libgnomevfs/gnome-vfs-utils.h>
+
+ #include <libintl.h>
+ #define _(String) gettext (String)
+@@ -418,7 +416,6 @@
+ state_from_config();
+ load_recent_files_list();
+
+- gnome_vfs_init();
+ gtk_init(&argc, &argv);
+ init_gui();
+
+@@ -445,8 +442,6 @@
+
+ main_loop();
+
+- gnome_vfs_shutdown();
+-
+ return 0;
+ }
+
+@@ -1635,7 +1630,7 @@
+
+ void activate_url(GtkAboutDialog *about, const gchar *url, gpointer data)
+ {
+- gnome_vfs_url_show (url);
++ gtk_show_uri (NULL, url, GDK_CURRENT_TIME, NULL );
+ }
+
+ /*** Bound Function Helpers ***/
+@@ -1859,7 +1856,7 @@
+ char* url;
+
+ url = dsprintf("file://%s/%s", DOCDIR, filename);
+- gnome_vfs_url_show(url);
++ gtk_show_uri (NULL, url, GDK_CURRENT_TIME, NULL );
+ free(url);
+ }
+
+--- lucidlife-0.9.2/lucidlife.desktop.in
++++ lucidlife-0.9.2/lucidlife.desktop.in
+@@ -2,8 +2,7 @@
+ Name=LucidLife
+ Comment=A user-friendly version of Conway's game of life
+ Exec=lucidlife
+-Icon=lucidlife.png
++Icon=lucidlife
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Game;
+-Encoding=UTF-8
++Categories=GNOME;GTK;Game;
diff --git a/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch b/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch
new file mode 100644
index 000000000000..af74e85e8c77
--- /dev/null
+++ b/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.old 2011-06-17 17:31:54.078600741 +0200
++++ src/Makefile.am 2011-06-17 17:32:05.491299944 +0200
+@@ -2,7 +2,7 @@
+ -DDATADIR=\""$(datadir)/lucidlife"\" \
+ -DDOCDIR=\""$(datadir)/doc/lucidlife"\"
+
+-LIBS = $(GNOME_LIBS)
++LIBS = $(GNOME_LIBS) -lX11
+
+ bin_PROGRAMS = lucidlife
+
diff --git a/games-misc/lucidlife/lucidlife-0.9.2.ebuild b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
new file mode 100644
index 000000000000..8c92724bc16a
--- /dev/null
+++ b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="A Conway's Life simulator written in GTK+2 - fork from Gtklife"
+HOMEPAGE="http://gtk-apps.org/content/show.php/LucidLife?content=130867"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gnome-vfs.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+ intltoolize --force --copy --automake || die
+}
+
+src_install() {
+ emake install \
+ desktopdir=/usr/share/applications \
+ pixmapdir=/usr/share/pixmaps \
+ DESTDIR="${D}"
+
+ prepgamesdirs
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/games-misc/lucidlife/metadata.xml b/games-misc/lucidlife/metadata.xml
new file mode 100644
index 000000000000..a562c4775bb2
--- /dev/null
+++ b/games-misc/lucidlife/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+