summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/shaaft
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/shaaft')
-rw-r--r--games-puzzle/shaaft/Manifest1
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch18
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch11
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-gcc43.patch23
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-libpng15.patch20
-rw-r--r--games-puzzle/shaaft/metadata.xml8
-rw-r--r--games-puzzle/shaaft/shaaft-0.5.0.ebuild55
7 files changed, 136 insertions, 0 deletions
diff --git a/games-puzzle/shaaft/Manifest b/games-puzzle/shaaft/Manifest
new file mode 100644
index 000000000000..e44f57f8c8e8
--- /dev/null
+++ b/games-puzzle/shaaft/Manifest
@@ -0,0 +1 @@
+DIST Shaaft-0.5.0.tar.bz2 512996 SHA256 db8040c4fee36da9ec9653fd6c04ffb21112c4c9c2297ee66f08b94efa61dc80 SHA512 8fce8f1b8e2cfd78832a5f328d95c186bbd1c96a66685e87f993879e96564d8c9051576c3c822d7dbdb59141d71726ced08a07390b298c3d26969f2b59dceedf WHIRLPOOL 135128793b9f99c917af5de5dd24662ff1970550a68a140869c94c71278e7ad9fc38c8b0e9108078b0bb02a41ee46e3d26a810ec6fc9e06075874a39cbb1f2ce
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch
new file mode 100644
index 000000000000..de3d59c90771
--- /dev/null
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch
@@ -0,0 +1,18 @@
+--- Shaaft-0.5.0.orig/utils/HashString.hpp
++++ Shaaft-0.5.0/utils/HashString.hpp
+@@ -21,6 +21,7 @@ using namespace std;
+
+ namespace HASH_NAMESPACE
+ {
++ template <>
+ struct hash<const string>
+ {
+ //a simple hash function for string
+@@ -32,6 +33,7 @@ namespace HASH_NAMESPACE
+ }
+ };
+
++ template <>
+ struct hash<string>
+ {
+ //a simple hash function for string
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch
new file mode 100644
index 000000000000..87b07f109d2f
--- /dev/null
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch
@@ -0,0 +1,11 @@
+--- utils/hashMap.hpp.old
++++ utils/hashMap.hpp
+@@ -14,7 +14,7 @@
+ //
+ #if defined( __GNUC__ )
+
+-# if (__GNUC__ == 3)
++# if (__GNUC__ >= 3)
+ # include <ext/hash_map>
+
+ # if (__GNUC_MINOR__ == 0)
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc43.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc43.patch
new file mode 100644
index 000000000000..2ddb37c75514
--- /dev/null
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc43.patch
@@ -0,0 +1,23 @@
+--- utils/ResourceManager.cpp
++++ utils/ResourceManager.cpp
+@@ -17,6 +17,7 @@
+ #include <dirent.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <cstring>
+
+ #include <Trace.hpp>
+ #include <ResourceManager.hpp>
+--- utils/Value.hpp
++++ utils/Value.hpp
+@@ -15,8 +15,9 @@
+ #ifndef _Value_hpp_
+ #define _Value_hpp_
+
+-#include <stdio.h>
++#include <cstdio>
+ #include <string>
++#include <cstdlib>
+
+ #include <Trace.hpp>
+
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-libpng15.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-libpng15.patch
new file mode 100644
index 000000000000..6773242ea6dc
--- /dev/null
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-libpng15.patch
@@ -0,0 +1,20 @@
+--- utilssdl/PNG.cpp
++++ utilssdl/PNG.cpp
+@@ -45,7 +45,7 @@
+ {
+ png_uint_32 check;
+
+- check = fwrite( data, 1, length, (FILE *)(png->io_ptr));
++ check = fwrite( data, 1, length, (FILE *)(png_get_io_ptr(png)));
+ if( check != length)
+ {
+ png_error( png, "Write Error");
+@@ -72,7 +72,7 @@
+ return false;
+ }
+
+- if( setjmp(_png->jmpbuf))
++ if( setjmp(png_jmpbuf(_png)))
+ {
+ fclose( fp);
+ png_destroy_write_struct(&_png, (png_infopp)NULL);
diff --git a/games-puzzle/shaaft/metadata.xml b/games-puzzle/shaaft/metadata.xml
new file mode 100644
index 000000000000..8b6d907abada
--- /dev/null
+++ b/games-puzzle/shaaft/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">criticalmass</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/shaaft/shaaft-0.5.0.ebuild b/games-puzzle/shaaft/shaaft-0.5.0.ebuild
new file mode 100644
index 000000000000..57baf97814db
--- /dev/null
+++ b/games-puzzle/shaaft/shaaft-0.5.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="A falling block game similar to Blockout"
+HOMEPAGE="http://packages.gentoo.org/package/games-puzzle/shaaft"
+SRC_URI="mirror://sourceforge/criticalmass/${P/s/S}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-libs/libsdl[sound,opengl,video]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-image[png]"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/s/S}
+
+src_prepare() {
+ sed -i \
+ -e 's:DATA_DIR:"'${GAMES_DATADIR}'\/'${PN/s/S}\/'":g' \
+ game/main.cpp || die
+
+ sed -i \
+ -e 's:png12:png:g' \
+ -e '/^CFLAGS=""/d' \
+ -e '/^CXXFLAGS=""/d' \
+ configure.in || die
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc34.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --disable-optimize
+}
+
+src_install() {
+ DOCS="TODO.txt" default
+ rm -f "${D}/${GAMES_BINDIR}"/Packer
+ prepgamesdirs
+}