summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild')
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
new file mode 100644
index 000000000000..6b71aae8bc04
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+MY_P=${PN}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="http://daimonin.svn.sourceforge.net/viewvc/daimonin/main/client/?view=tar&pathrev=6021
+ -> daimonin-client-0.10.5.tar.gz
+ music? ( mirror://sourceforge/daimonin/Addon%20packs/Music/AllMusic.zip
+ -> daimonin-client-AllMusic-20100827.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="music debug"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ dev-games/physfs
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ music? ( app-arch/unzip )"
+
+S=${WORKDIR}/client/make/linux
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use music ; then
+ cd client/media
+ rm -f *
+ unpack ${PN}-AllMusic-20100827.zip
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nozlib.patch
+ rm ../../src/include/z{lib,conf}.h
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:daimonin-updater::' \
+ Makefile.am \
+ || die "sed failed"
+ eautoreconf
+ cd ../../src
+ epatch "${FILESDIR}"/${P}-datadir.patch
+}
+
+src_configure() {
+ egamesconf \
+ --disable-simplelayout \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ cd ../..
+ dodoc README*
+ newicon bitmaps/pentagram.png ${PN}.png
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}