summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-09 20:18:32 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 09:41:15 +0300
commit9988be2f15c96d5ef1773df8474099260b3aae22 (patch)
tree59dac65b88ec9a77685c6cfb0031ad381166c0e5 /games-rpg/wastesedge/wastesedge-0.3.8.ebuild
parentgames-rpg/adonthell: update to 0.3.8 (diff)
downloadgentoo-9988be2f15c96d5ef1773df8474099260b3aae22.tar.gz
gentoo-9988be2f15c96d5ef1773df8474099260b3aae22.tar.bz2
gentoo-9988be2f15c96d5ef1773df8474099260b3aae22.zip
games-rpg/wastesedge: update to 0.3.8
Migrated to python3, minor fixes for EAPI7. Closes: https://bugs.gentoo.org/735354 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-rpg/wastesedge/wastesedge-0.3.8.ebuild')
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-rpg/wastesedge/wastesedge-0.3.8.ebuild b/games-rpg/wastesedge/wastesedge-0.3.8.ebuild
new file mode 100644
index 000000000000..8e420c1b4f89
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.nongnu.org/download/"
+SRC_URI="https://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.8[${PYTHON_SINGLE_USEDEP}]
+ nls? ( virtual/libintl )"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}/${P}_version-handling.patch" )
+DOCS=( AUTHORS ChangeLog NEWS PLAYING README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-adonthell-binary="/usr/bin/adonthell"
+}