summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-23 19:00:30 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-23 19:21:47 +0200
commit3f20fce72abfaacfaf99ef38f82509a1e1f4d1b2 (patch)
treef38758d1d752631c8cc9e6f9b89844b714c7a491 /games-server/steamcmd/steamcmd-1.0-r3.ebuild
parentgames-server/bedrock-server: add custom attach command (diff)
downloadgentoo-3f20fce72abfaacfaf99ef38f82509a1e1f4d1b2.tar.gz
gentoo-3f20fce72abfaacfaf99ef38f82509a1e1f4d1b2.tar.bz2
gentoo-3f20fce72abfaacfaf99ef38f82509a1e1f4d1b2.zip
games-server/steamcmd: switch to dtach
This version changes the usage from app-misc/screen to app-misc/dtach. A custom attach command is also added with that switch. Since at least the valve game server are running as an interactive console process in background, this custom command 'attach' enables the possibility to connect with dtach to that interactive console and send commands to the running server. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-server/steamcmd/steamcmd-1.0-r3.ebuild')
-rw-r--r--games-server/steamcmd/steamcmd-1.0-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-server/steamcmd/steamcmd-1.0-r3.ebuild b/games-server/steamcmd/steamcmd-1.0-r3.ebuild
new file mode 100644
index 000000000000..1c33b66301d8
--- /dev/null
+++ b/games-server/steamcmd/steamcmd-1.0-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="This is the command-line version of the Steam client for dedicated servers"
+HOMEPAGE="https://developer.valvesoftware.com/wiki/SteamCMD"
+SRC_URI="https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ Steam"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ acct-group/steamcmd
+ acct-user/steamcmd
+ app-misc/dtach
+"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="
+ opt/steamcmd/linux32/libstdc++.so.6
+ opt/steamcmd/linux32/steamcmd
+"
+
+src_install() {
+ diropts -o steamcmd -g steamcmd
+ dodir /opt/steamcmd
+ keepdir /opt/steamcmd/{.steam,.steam/sdk32,linux32}
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd
+ doexe steamcmd.sh
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd/linux32
+ doexe linux32/steamcmd linux32/libstdc++.so.6
+
+ newinitd "${FILESDIR}"/steamcmd.initd-r2 steamcmd
+ newconfd "${FILESDIR}"/steamcmd.confd-r2 steamcmd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}