summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-05-27 23:49:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-05-28 00:33:43 +0200
commita6cc2e8778e1a0095d91c407a1d9f04fde96350f (patch)
treee2343fd91293d1e0b83ce4f2ed6b9f142e192d06 /games-simulation/openrct2/files
parentgames-simulation/openrct2: x86 stable (diff)
downloadgentoo-a6cc2e8778e1a0095d91c407a1d9f04fde96350f.tar.gz
gentoo-a6cc2e8778e1a0095d91c407a1d9f04fde96350f.tar.bz2
gentoo-a6cc2e8778e1a0095d91c407a1d9f04fde96350f.zip
games-simulation/openrct2: drop 0.3.5.1-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-simulation/openrct2/files')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.2.4-include-additional-paths.patch33
-rw-r--r--games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch58
2 files changed, 0 insertions, 91 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.2.4-include-additional-paths.patch b/games-simulation/openrct2/files/openrct2-0.2.4-include-additional-paths.patch
deleted file mode 100644
index d7c3bb7b4442..000000000000
--- a/games-simulation/openrct2/files/openrct2-0.2.4-include-additional-paths.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 370b6c6ee48dd1ccc68e03f4bba3e9a2cb2067aa Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad@kostecki.com>
-Date: Sat, 9 Nov 2019 22:32:03 +0100
-Subject: [PATCH] src/openrct2/config/Config.cpp: Search additional paths for
- rct data.
-
-With '/usr/share/openrct2/rct{1,2}_data' added into the search path list,
-it makes possible to install rct{1,2} game files globally,
-so every user on a linux system can run OpenRCT2 directly.
----
- src/openrct2/config/Config.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/openrct2/config/Config.cpp b/src/openrct2/config/Config.cpp
-index 08d59488eea..969533f8820 100644
---- a/src/openrct2/config/Config.cpp
-+++ b/src/openrct2/config/Config.cpp
-@@ -615,6 +615,7 @@ namespace Config
- log_verbose("config_find_rct1_path(...)");
-
- static constexpr const utf8* searchLocations[] = {
-+ R"(/usr/share/openrct2/rct1_data)",
- R"(C:\Program Files\Steam\steamapps\common\Rollercoaster Tycoon Deluxe)",
- R"(C:\Program Files (x86)\Steam\steamapps\common\Rollercoaster Tycoon Deluxe)",
- R"(C:\GOG Games\RollerCoaster Tycoon Deluxe)",
-@@ -659,6 +660,7 @@ namespace Config
- log_verbose("config_find_rct2_path(...)");
-
- static constexpr const utf8* searchLocations[] = {
-+ R"(/usr/share/openrct2/rct2_data)",
- R"(C:\Program Files\Steam\steamapps\common\Rollercoaster Tycoon 2)",
- R"(C:\Program Files (x86)\Steam\steamapps\common\Rollercoaster Tycoon 2)",
- R"(C:\GOG Games\RollerCoaster Tycoon 2 Triple Thrill Pack)",
diff --git a/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch b/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch
deleted file mode 100644
index 97a529c6a8e2..000000000000
--- a/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From cb6d7418c53e10bd4120891f6a2312d3ef839ca8 Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conikost@gentoo.org>
-Date: Sun, 12 Dec 2021 23:04:58 +0100
-Subject: [PATCH] CMakeLists.txt: update CCache handling (#16185)
-
-This PR updated slightly the handling of CCache. With the current
-implementation, when CCache is not being installed, CMake will complain,
-that OPENRCT2_USE_CCACHE is not set.
-
-This logic is slightly updated, so the option OPENRCT2_USE_CCACHE is always
-being available and when this option is enabled (default ON), it will
-search for CCache and warn, if it's not found.
-
-The idea behind is, as in Gentoo, we never let CCache be used by the
-package itself, instead, we enabled it globally. But this the old logic,
-on systems, which don't have CCache installed, it will complain about
-OPENRCT2_USE_CCACHE not being used, but we have to make sure, OpenRCT2
-will never use by itself CCache and this message will be gone..
-
-Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
----
- CMakeLists.txt | 23 +++++++++++++----------
- 1 file changed, 13 insertions(+), 10 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8d202cf5a9b8..566f3a8a9688 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -8,16 +8,19 @@ endif()
- # if it is available
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
-
--find_package(CCache)
--
--if (CCache_FOUND)
-- option(OPENRCT2_USE_CCACHE "Use CCache to improve recompilation speed (optional)" ON)
-- if (OPENRCT2_USE_CCACHE)
-- # Use e.g. "ccache clang++" instead of "clang++"
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCache_EXECUTABLE}")
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK "${CCache_EXECUTABLE}")
-- endif (OPENRCT2_USE_CCACHE)
--endif (CCache_FOUND)
-+option(OPENRCT2_USE_CCACHE "Use CCache to improve recompilation speed (optional)" ON)
-+
-+if (OPENRCT2_USE_CCACHE)
-+ find_package(CCache)
-+
-+ if (CCache_FOUND)
-+ # Use e.g. "ccache clang++" instead of "clang++"
-+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCache_EXECUTABLE}")
-+ set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK "${CCache_EXECUTABLE}")
-+ else()
-+ message("Usage of CCache was enabled, but CCache was not found, so CCache is not being enabled.")
-+ endif()
-+endif (OPENRCT2_USE_CCACHE)
-
- if (APPLE)
- execute_process(COMMAND /usr/bin/uname -m OUTPUT_VARIABLE SYSTEM_MACOS_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)