summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild')
-rw-r--r--games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild b/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild
new file mode 100644
index 000000000000..f80aec69f12e
--- /dev/null
+++ b/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CDROM_OPTIONAL="yes"
+inherit eutils unpacker cdrom games
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="the hyped indie game of the year. By the Uplink creators"
+HOMEPAGE="http://www.darwinia.co.uk/support/linux.html"
+SRC_URI="http://www.introversion.co.uk/darwinia/downloads/${PN}-full-${MY_PV}.sh"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+RDEPEND="
+ ~virtual/libstdc++-3.3
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/lib/darwinia.bin.x86"
+
+src_unpack() {
+ use cdinstall && cdrom_get_cds gamefiles/main.dat
+ unpack_makeself
+}
+
+src_install() {
+ insinto "${dir}"/lib
+ exeinto "${dir}"/lib
+
+ doins lib/{language,patch}.dat
+ doexe lib/darwinia.bin.x86 lib/open-www.sh
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/darwinia
+
+ if use cdinstall ; then
+ doins "${CDROM_ROOT}"/gamefiles/{main,sounds}.dat
+ fi
+
+ dodoc README
+ newicon darwinian.png darwinia.png
+
+ games_make_wrapper darwinia ./darwinia "${dir}" "${dir}"
+ make_desktop_entry darwinia "Darwinia"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ if ! use cdinstall; then
+ ewarn "To play the game, you need to copy main.dat and sounds.dat"
+ ewarn "from gamefiles/ on the game CD to ${dir}/lib/."
+ fi
+ games_pkg_postinst
+}