summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/ufo-ai/ufo-ai-2.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/ufo-ai/ufo-ai-2.4.ebuild')
-rw-r--r--games-strategy/ufo-ai/ufo-ai-2.4.ebuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/games-strategy/ufo-ai/ufo-ai-2.4.ebuild b/games-strategy/ufo-ai/ufo-ai-2.4.ebuild
new file mode 100644
index 000000000000..4c3c9fe064d2
--- /dev/null
+++ b/games-strategy/ufo-ai/ufo-ai-2.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic games
+
+MY_P=${P/o-a/oa}
+
+DESCRIPTION="UFO: Alien Invasion - X-COM inspired strategy game"
+HOMEPAGE="http://ufoai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ufoai/${MY_P}-source.tar.bz2
+ mirror://sourceforge/ufoai/${MY_P}-data.tar
+ http://mattn.ninex.info/1maps.pk3"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug dedicated editor"
+
+# Dependencies and more instructions can be found here:
+# http://ufoai.ninex.info/wiki/index.php/Compile_for_Linux
+DEPEND="!dedicated? (
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ virtual/jpeg
+ media-libs/libpng:0
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-proto/xf86vidmodeproto
+ )
+ net-misc/curl
+ sys-devel/gettext
+ sys-libs/zlib
+ editor? (
+ dev-libs/libxml2
+ virtual/jpeg
+ media-libs/openal
+ x11-libs/gtkglext
+ x11-libs/gtksourceview:2.0
+ )"
+
+S=${WORKDIR}/${MY_P}-source
+
+src_prepare() {
+ if has_version '>=sys-libs/zlib-1.2.5.1-r1' ; then
+ sed -i -e '1i#define OF(x) x' src/common/ioapi.h || die
+ fi
+
+ # don't try to use the system mini-xml
+ sed -i -e '/mxml/d' configure || die
+
+ epatch \
+ "${FILESDIR}"/${P}-mathlib.patch \
+ "${FILESDIR}"/${P}-anon.patch \
+ "${FILESDIR}"/${P}-locale.patch
+
+ cp "${DISTDIR}"/1maps.pk3 "${WORKDIR}"/base/ || die
+ mv "${WORKDIR}"/base/ "${S}"/ || die
+}
+
+src_configure() {
+ # they are special and provide hand batched configure file
+ local myconf="
+ --disable-dependency-tracking
+ $(use_enable !debug release)
+ $(use_enable editor ufo2map)
+ $(use_enable editor uforadiant)
+ --enable-ufoded
+ --bindir="${GAMES_BINDIR}"
+ --libdir="$(games_get_libdir)"
+ --datadir="${GAMES_DATADIR}/${PN/-}"
+ --localedir="${EPREFIX}/usr/share/locale/"
+ --prefix="${GAMES_PREFIX}"
+ "
+ echo "./configure ${myconf}"
+ ./configure ${myconf} || die
+}
+
+src_compile() {
+ emake
+ emake lang
+
+ if use editor; then
+ emake uforadiant
+ fi
+}
+
+src_install() {
+ newicon src/ports/linux/ufo.png ${PN}.png
+ dobin ufoded
+ make_desktop_entry ufoded "UFO: Alien Invasion Server" ${PN}
+ if ! use dedicated; then
+ dobin ufo
+ make_desktop_entry ufo "UFO: Alien Invasion" ${PN}
+ fi
+
+ if use editor; then
+ dobin ufo2map ufomodel
+ fi
+
+ # install data
+ insinto "${GAMES_DATADIR}"/${PN/-}
+ doins -r base
+ rm -rf "${ED}/${GAMES_DATADIR}/${PN/-}/base/game.so"
+ dogameslib base/game.so
+
+ # move translations where they belong
+ dodir "${GAMES_DATADIR_BASE}/locale"
+ mv "${ED}/${GAMES_DATADIR}/${PN/-}/base/i18n/"* \
+ "${ED}/${GAMES_DATADIR_BASE}/locale/" || die
+ rm -rf "${ED}/${GAMES_DATADIR}/${PN/-}/base/i18n/" || die
+
+ prepgamesdirs
+}