summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-22 13:13:03 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-22 14:53:31 +0100
commitefa1712b221c0fb14a2dc1dd5bf33e10ed76bd7c (patch)
treea400a6c34e68925259aabad89af1306f2955a222 /games-util
parentdev-python/caldav: enable py3.13 (diff)
downloadgentoo-efa1712b221c0fb14a2dc1dd5bf33e10ed76bd7c.tar.gz
gentoo-efa1712b221c0fb14a2dc1dd5bf33e10ed76bd7c.tar.bz2
gentoo-efa1712b221c0fb14a2dc1dd5bf33e10ed76bd7c.zip
games-util/sc-controller: Drop old 0.4.8.9-r1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch24
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild58
3 files changed, 0 insertions, 83 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index fae9be50628e..6543fbc58aa3 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1,2 +1 @@
DIST sc-controller-0.4.8.11.tar.gz 2566642 BLAKE2B 64e910e27ceb93938d6250ae058a5df102922f36f4e1e7aa5d2f761b93bbcf34296eefabb10145b4e1b7030c05af341ccb6cbe01df7ce891c69f8d8fceefdb30 SHA512 e591e1c44763c38a18f09f8d5d9fcdb7f46c60d8f4dc040d82e48617d0f960abb6ec608188724838060dbe532589453b0be2c1d94686decef657205f8e8efcec
-DIST sc-controller-0.4.8.9.tar.gz 2541647 BLAKE2B f4e4ebcd15f8c32f292293ea21a0c30655fedefba310991082ece3b9159b52700178a31da4b3e7a172e40fde4e718403c0945387f3781628e09fa1fc086eee93 SHA512 e0848d366f6f80c36670adcda717b792b6993e7383c01e969c0478cf187bcdb891ea9c434271f24e7f5dfc96d8f321f953f610bb8efeb6ed843b7cd069b9b18f
diff --git a/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch b/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch
deleted file mode 100644
index 283dbba8be98..000000000000
--- a/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/scc/lib/__init__.py b/scc/lib/__init__.py
-index 33d1486dd..0fe3141a5 100644
---- a/scc/lib/__init__.py
-+++ b/scc/lib/__init__.py
-@@ -1,3 +1,3 @@
- #!/usr/bin/env python2
-
--from enum import Enum, IntEnum, unique
-+from .enum import Enum, IntEnum, unique
-diff --git a/tests/test_strings/test_keys.py b/tests/test_strings/test_keys.py
-new file mode 100644
-index 000000000..f118d373c
---- /dev/null
-+++ b/tests/test_strings/test_keys.py
-@@ -0,0 +1,8 @@
-+from scc.uinput import Keys
-+from scc.lib import IntEnum
-+
-+class TestKeys(object):
-+ def test_up_str(self):
-+ assert isinstance(Keys.KEY_UP, IntEnum)
-+ assert Keys.KEY_UP.name == "KEY_UP"
-+ assert str(Keys.KEY_UP) == "Keys.KEY_UP"
-\ No newline at end of file
diff --git a/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild b/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild
deleted file mode 100644
index b7892049fc8e..000000000000
--- a/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 linux-info xdg
-
-DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
-HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
-SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+udev wayland"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/evdev[${PYTHON_USEDEP}]
- dev-python/pygobject[${PYTHON_USEDEP},cairo]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/vdf[${PYTHON_USEDEP}]
- ')
- gnome-base/librsvg[introspection]
- virtual/libusb
- x11-libs/gtk+:3[introspection]
- udev? ( games-util/game-device-udev-rules )
- wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/Ryochan7/sc-controller/pull/82
- "${FILESDIR}/${P}-python3_11.patch"
-)
-
-pkg_setup() {
- local CONFIG_CHECK="~INPUT_UINPUT"
-
- linux-info_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # This test fails. Don't know why but seems unimportant.
- rm -v tests/test_glade.py || die
-}
-
-src_install() {
- distutils-r1_src_install
- rm -r "${ED}"/usr/lib/udev/ || die
-}