summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-22 16:54:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-22 17:42:53 +0100
commitb3f9e0aeec23a18974bd5d11c66e18fa827743ee (patch)
tree0d8fac5157c1ff679803ec7828ed91bc2ba52547 /gnome-extra/cjs
parentdev-util/spirv-llvm-translator: Remove old (diff)
downloadgentoo-b3f9e0aeec23a18974bd5d11c66e18fa827743ee.tar.gz
gentoo-b3f9e0aeec23a18974bd5d11c66e18fa827743ee.tar.bz2
gentoo-b3f9e0aeec23a18974bd5d11c66e18fa827743ee.zip
gnome-extra/cjs: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/cjs-5.6.1.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 29fe45dfc6c9..2d97a26bf010 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,2 +1 @@
-DIST cjs-5.6.1.tar.gz 794907 BLAKE2B 9ec6d5ffb33a28dca96d640da7b499e81751d5889dd0caec354fdf41de7b42c8d8edd737def68c2506c94af7a69a4d3433c459da2a5884f2668f14eac22163a0 SHA512 35662d78174d428610642198d7777a2c19137cd61dce93de69011fea235b0f461a2072ff219da0f18ef36068c1e3e5c2dc88684493b900a12fc1cd0b32503ae5
DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
diff --git a/gnome-extra/cjs/cjs-5.6.1.ebuild b/gnome-extra/cjs/cjs-5.6.1.ebuild
deleted file mode 100644
index 25a3e01843cd..000000000000
--- a/gnome-extra/cjs/cjs-5.6.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit flag-o-matic meson pax-utils python-any-r1 virtualx
-
-DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
-HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
-SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-lang/spidermonkey-78.2.0:78
- >=dev-libs/glib-2.66.0:2
- >=dev-libs/gobject-introspection-1.66.1:=
- >=dev-libs/libffi-3.3:0=
-
- cairo? ( x11-libs/cairo[glib,svg(+),X] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="
- ${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- x11-libs/gtk+:3[introspection]
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.6.1-clang15.patch
-)
-
-src_prepare() {
- default
- python_fix_shebang build
-}
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- meson_src_install
-
- if use examples; then
- docinto examples
- dodoc "${S}"/examples/*
- fi
-
- # Required for cjs-console to run correctly on PaX systems
- pax-mark mr "${ED}/usr/bin/cjs-console"
-}