summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-12-31 00:12:59 +0200
committerMart Raudsepp <leio@gentoo.org>2019-12-31 00:36:04 +0200
commite41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b (patch)
tree3d388fd84eae0a5c80f6727c70546f5a58b4ffff /gnome-extra/zenity/zenity-3.32.0.ebuild
parentsys-boot/raspberrypi-firmware: add ~arm64 keyword (diff)
downloadgentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.tar.gz
gentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.tar.bz2
gentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.zip
gnome-extra/zenity: bump to 3.32.0
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity/zenity-3.32.0.ebuild')
-rw-r--r--gnome-extra/zenity/zenity-3.32.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/zenity/zenity-3.32.0.ebuild b/gnome-extra/zenity/zenity-3.32.0.ebuild
new file mode 100644
index 000000000000..a22518e62371
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.32.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3[X]
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}