summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-07-07 03:24:58 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-15 21:21:44 +0200
commit3269b2238c5f9f6a1e09950d7c661968a72357da (patch)
tree304677ed51768093d8f3a06e1a82b43570717d93 /gnome-extra
parentgui-libs/libadwaita: drop 1.5.0 (diff)
downloadgentoo-3269b2238c5f9f6a1e09950d7c661968a72357da.tar.gz
gentoo-3269b2238c5f9f6a1e09950d7c661968a72357da.tar.bz2
gentoo-3269b2238c5f9f6a1e09950d7c661968a72357da.zip
gnome-extra/zenity: Bump to 4.0.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37467 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-4.0.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 0817b1a42a33..219171d06d8d 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1 +1,2 @@
DIST zenity-4.0.1.tar.xz 3093476 BLAKE2B 47ea26adc69bd302e8c59d2fae9c5647fbbadbfd9c61870d6ab5e85cf2bc62af415236cef782ae6f790a756c265113bb23e5be449447270dc0ec41cae23506a5 SHA512 f84e14fd66dbe6bd21d030c1879d8d44250bc8c0661c5ccb6cad7fe8d257e4b01427ce27894cf5a5c27566113587f6b34adc9051826e870e44b836b5c63fb11f
+DIST zenity-4.0.2.tar.xz 3095860 BLAKE2B bb72db8ad7ff7d73e7bc515de3c98cf2067763406e6ebfb093fdff14f728710d44dcd7c5f2bb6e066adbd051a508e26758ba052c5ef3efa895aac234f61eaf55 SHA512 2a8ba44d1189ffd3e7630e54418f6ce16d5187b8dc282ea921313413968ff4f20496f569c5dfd403256114ef4f00c33f2500fc08323b46d541493d7ab87bb365
diff --git a/gnome-extra/zenity/zenity-4.0.2.ebuild b/gnome-extra/zenity/zenity-4.0.2.ebuild
new file mode 100644
index 000000000000..5aa24919bf45
--- /dev/null
+++ b/gnome-extra/zenity/zenity-4.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}