summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-04 14:23:49 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-04 14:41:48 -0500
commit61fb2967dfe3da729a2cc6af871330a862cbeb08 (patch)
tree8ffe9dca03686fa851b836a6d58471d886a0b0d3 /gnome-extra
parentsys-apps/xdg-desktop-portal-gtk: Depend on gsettings-desktop-schemas (diff)
downloadgentoo-61fb2967dfe3da729a2cc6af871330a862cbeb08.tar.gz
gentoo-61fb2967dfe3da729a2cc6af871330a862cbeb08.tar.bz2
gentoo-61fb2967dfe3da729a2cc6af871330a862cbeb08.zip
gnome-extra/gnome-directory-thumbnailer: Update for gnome-desktop-43 API change
Also update to EAPI=8. Closes: https://bugs.gentoo.org/882471 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-directory-thumbnailer/files/0.1.11-Update-for-gnome-desktop-43-API-change.patch37
-rw-r--r--gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11-r1.ebuild (renamed from gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11.ebuild)12
2 files changed, 45 insertions, 4 deletions
diff --git a/gnome-extra/gnome-directory-thumbnailer/files/0.1.11-Update-for-gnome-desktop-43-API-change.patch b/gnome-extra/gnome-directory-thumbnailer/files/0.1.11-Update-for-gnome-desktop-43-API-change.patch
new file mode 100644
index 000000000000..9094c07122d2
--- /dev/null
+++ b/gnome-extra/gnome-directory-thumbnailer/files/0.1.11-Update-for-gnome-desktop-43-API-change.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/882471
+https://gitlab.gnome.org/GNOME/gnome-directory-thumbnailer/-/merge_requests/2
+
+From 8b39714ff8fd5de6643b5fdcf7fb01da35b82334 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sun, 4 Dec 2022 14:20:23 -0500
+Subject: [PATCH] Update for gnome-desktop-43 API change
+
+Fixes: https://gitlab.gnome.org/GNOME/gnome-directory-thumbnailer/-/issues/8
+---
+ src/main.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/main.c b/src/main.c
+index 64aa7da..c5c6d34 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -373,12 +373,16 @@ copy_thumbnail_from_file (GnomeDesktopThumbnailFactory *factory, const gchar *fi
+ g_setenv ("GNOME_DIRECTORY_THUMBNAILER_RECURSION_LIMIT", new_recursion_limit_str, TRUE);
+ g_free (new_recursion_limit_str);
+
++#if defined(GNOME_DESKTOP_PLATFORM_VERSION) && GNOME_DESKTOP_PLATFORM_VERSION >= 43
++ pixbuf = gnome_desktop_thumbnail_factory_generate_thumbnail (factory, file_uri, file_mime_type, NULL, error);
++#else
+ pixbuf = gnome_desktop_thumbnail_factory_generate_thumbnail (factory, file_uri, file_mime_type);
+ if (pixbuf == NULL) {
+ /* gnome-desktop doesn't set an error so we have to. */
+ g_debug ("Error generating thumbnail.");
+ g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_NOENT, _("Error generating thumbnail for file ‘%s’."), file_uri);
+ }
++#endif
+ } else {
+ g_debug ("Didn’t generate thumbnail due to hitting the recursion limit.");
+ g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_NOENT, _("Error generating thumbnail for file ‘%s’: recursion limit reached."), file_uri);
+--
+2.37.4
+
diff --git a/gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11.ebuild b/gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11-r1.ebuild
index c040bc6b4468..415cfeb9c570 100644
--- a/gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11.ebuild
+++ b/gnome-extra/gnome-directory-thumbnailer/gnome-directory-thumbnailer-0.1.11-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gnome2
DESCRIPTION="Thumbnail generator for directories"
@@ -9,16 +9,20 @@ HOMEPAGE="https://wiki.gnome.org/Projects/GnomeDirectoryThumbnailer"
LICENSE="LGPL-2.1+"
SLOT="0"
-IUSE=""
KEYWORDS="amd64 x86"
+PATCHES=(
+ "${FILESDIR}"/${PV}-Update-for-gnome-desktop-43-API-change.patch
+)
+
RDEPEND="
>=dev-libs/glib-2.35:2
>=x11-libs/gdk-pixbuf-2.36.5:2
>=gnome-base/gnome-desktop-2.2:3=
x11-libs/gtk+:3
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-util/intltool-0.40
virtual/pkgconfig
"