summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-10 20:56:22 -0300
committerSam James <sam@gentoo.org>2024-10-07 03:39:26 +0100
commit92ced3057c1380e7387b3fb2d4236bcc34d4f347 (patch)
treeb702d744f6978753f3df2e93e138a430dadcda93 /gnome-extra
parentdev-ruby/nokogiri-diff: Stabilize 0.3.0 ppc64, #941065 (diff)
downloadgentoo-92ced3057c1380e7387b3fb2d4236bcc34d4f347.tar.gz
gentoo-92ced3057c1380e7387b3fb2d4236bcc34d4f347.tar.bz2
gentoo-92ced3057c1380e7387b3fb2d4236bcc34d4f347.zip
gnome-extra/gucharmap: Bump to 16.0.1
[sam: Restore py3.10. Note that bumping this because stable unicode-data causes a conflict here so need to be in sync.] Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38739 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-16.0.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 2df302162eeb..fc20b72dc2d2 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1 +1,2 @@
DIST gucharmap-15.1.2.tar.bz2 1455600 BLAKE2B 991388c67451df701533d9935021644aa549a373d07dbdca47ee47e76b419533e5ecf16ddfb4603467f7750fe6934fbef37ecd88795ebf11e066a3f1d76e327b SHA512 702276b0fd7804d4210b71e332a34206f27c0da5fefbf164a70881d97d0cbcd3cdb9f8b31e56ee449cb07688bdbbe6fa1d7fa8e7a5fe5c5b879a6ce828450e69
+DIST gucharmap-16.0.1.tar.bz2 1503713 BLAKE2B e77b0d9e12d73f38b8e32c078bed3be2e7a1a3c3d61578e79f539209f7af0106dca1b8201610c512ccc100bb2a239f57c097dd96f78c1959d64e67e7cf47345e SHA512 9816e6fda5c7a8ce34af41c55121e1291e07033a636955d3501c4eb57e290ca5e9ef74d7e622e3be1c85140fc55d4d21012a84c2a3bf3effc195bdb38740241b
diff --git a/gnome-extra/gucharmap/gucharmap-16.0.1.ebuild b/gnome-extra/gucharmap/gucharmap-16.0.1.ebuild
new file mode 100644
index 000000000000..bf7cce539d74
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-16.0.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="16.0.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+
+ !gnome-extra/gucharmap:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/glib:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}