summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-26 20:11:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-26 20:12:33 +0300
commit7cfe79de5e4f3610bd8f8df54386b59d1dd4cb28 (patch)
treedcd8439e38822df67560825f9d40707aa5219335 /gui-apps
parentgui-apps/mako: sync live ebuild (diff)
downloadgentoo-7cfe79de5e4f3610bd8f8df54386b59d1dd4cb28.tar.gz
gentoo-7cfe79de5e4f3610bd8f8df54386b59d1dd4cb28.tar.bz2
gentoo-7cfe79de5e4f3610bd8f8df54386b59d1dd4cb28.zip
gui-apps/swaybg: add 1.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swaybg/Manifest1
-rw-r--r--gui-apps/swaybg/swaybg-1.2.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/swaybg/Manifest b/gui-apps/swaybg/Manifest
index 4160f0ace994..7e14044460e7 100644
--- a/gui-apps/swaybg/Manifest
+++ b/gui-apps/swaybg/Manifest
@@ -1 +1,2 @@
DIST swaybg-1.2.0.tar.gz 16572 BLAKE2B 197daba2a049bd21c1609c7abc5241c1b8664dabd34b16d9664c2f7f6853028389f81ef3d8e7f13c8b8decda0a0149ff911b86cc079b11cdbc8f9c977c4e0e23 SHA512 e0c0d78a1887e8a6ff396305ea717be22ec316cd17ef7e2f61a0fe25f976ff12bb5fd48bf8dc7d99d7c9bf6948b4a00d99bf9ac68021080ae9c393ca84e86e0a
+DIST swaybg-1.2.1.tar.gz 16600 BLAKE2B 5b61bb5c5bc3074eaa08255b02d82bd07f66b9f090328d34fd55c971d81ce1bedca05ad0499bd1e09a4669880f7e26ce87460d51d50b602b278651bb3283379b SHA512 ea5f1e2db58eb6865e79b05b85e045bd07afa411d6d1cd4e08710c891ef0bc68d78af8fc500e6200824abad865bfe625b030c31d6c9f76cb6a46fefd2c0d5aa8
diff --git a/gui-apps/swaybg/swaybg-1.2.1.ebuild b/gui-apps/swaybg/swaybg-1.2.1.ebuild
new file mode 100644
index 000000000000..9456a6851de5
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-1.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gdk-pixbuf +man"
+
+DEPEND="
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.26
+ x11-libs/cairo
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature gdk-pixbuf)
+ )
+
+ meson_src_configure
+}