summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-13 22:46:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-13 22:50:01 +0200
commitea01d07c76b705e48d8d3a4600856746ce596e95 (patch)
tree11abb713ee2d1cf09ef62389e18dd03cbac691e0 /kde-apps/akonadi-contacts
parentdev-java/hawtjni-runtime: keyword ~arm64 (diff)
downloadgentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.tar.gz
gentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.tar.bz2
gentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.zip
kde-apps: Add KDE Applications 17.04.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-apps/akonadi-contacts')
-rw-r--r--kde-apps/akonadi-contacts/Manifest1
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-17.04.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/Manifest b/kde-apps/akonadi-contacts/Manifest
index da6c8b55ddc4..7eeef187e84c 100644
--- a/kde-apps/akonadi-contacts/Manifest
+++ b/kde-apps/akonadi-contacts/Manifest
@@ -1 +1,2 @@
DIST akonadi-contacts-17.04.2.tar.xz 347504 SHA256 7ff537c22e7489ddf4433ab80845455e3aa78fd233527a0774f0c9df1d73d53a SHA512 a2a2db27617d4ed77a620dc796acdd9b9ed968afab294500a654a69b9ad6ed45129bf04c62c7f163a6d71beb7a8d5aed205cf2cb8aa4d93bdb6ed8e5af7f606b WHIRLPOOL e17f941a95045e2e0aab7d80d831b5180e2e87ada884206afa78a01a186d5c8a9c54cf17328d4f9c44985bc3212a4e06155a27b958e509f76c06126caa61c23c
+DIST akonadi-contacts-17.04.3.tar.xz 347700 SHA256 5399633c4b312d4226ca169f3aa1da521d9bdd7ed46389d1ab7fabbcfc764e0f SHA512 5cb488b5840c1d401213ee656ee2e8bc219e51ba03c3625f6c39dccf6c1d53e0d7347f7f67e31019e7460cffe22ac32c4216bd75be2bf557912cd2587b0a6fd3 WHIRLPOOL e2cc7479fc3e99f2888edf284180b76469ab9c57048ac76edb6cc9d3439061a2736e63bb1f5b7875afdb65b099d2b72b451fd79600cd8e93217bc53733f82514
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-17.04.3.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-17.04.3.ebuild
new file mode 100644
index 000000000000..7030cb9808b1
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-17.04.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="prison"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+ prison? ( $(add_frameworks_dep prison) )
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package prison KF5Prison)
+ )
+
+ kde5_src_configure
+}