summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/dolphin
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-18.12.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 6dad96a5c497..f3610afa0fee 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-18.08.3.tar.xz 4859384 BLAKE2B 60361ce997e0e4734fe953f988774dbe28aef9dcb7c2837c3860cfad5f56345d4d635f1478ce42a1649a6d5bd0d3838f722c95a747e1c77f17828d0d38b0ab29 SHA512 f3017ecb67009292972876f27ade398699622cd4253e608d78b9c8dd7693bce2a1d742af5f51885b28c1765496b31f83ac25fda40ba330821b460622adc7ad7c
DIST dolphin-18.12.1.tar.xz 4865868 BLAKE2B 9f93d6d9607d296ad1452ba2bfb3285ca1b97d9b9b0e02ae5abc04da0f4279051559720591bbd74e8c0249d2b4c5814746814fb5d0deda6a75e9db2dbfc9827a SHA512 5975c594051f9bcc860026075631bb14ea920069826c1f1994b10dbf606b0474e552324ecf0bdd252deb83c9245e3f1af80502fd122806be41fc37851b96ef3c
+DIST dolphin-18.12.2.tar.xz 4867624 BLAKE2B 2ad271db86e37b57db90e676cf1e43fc441d4ec379ce8c96774c4896ce602edaec37fcd7adf0884ae1a43c1132e02b6dd1c6569dfe2f9c69624e759397b3147e SHA512 2e5fc55a20b5b091c4a8d3e842d05c170feb660fef62bca991543f6580ed858fd3d73fbd7135513603a6736360408ed372374a5c6473ff95c24b5117abd193f5
diff --git a/kde-apps/dolphin/dolphin-18.12.2.ebuild b/kde-apps/dolphin/dolphin-18.12.2.ebuild
new file mode 100644
index 000000000000..f92c86b8d18f
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.12.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "kde-apps/ark:${SLOT}" || \
+ elog "For compress/extract and other actions install kde-apps/ark:${SLOT}"
+
+ has_version "kde-apps/kleopatra:${SLOT}" || \
+ elog "For crypto actions install kde-apps/kleopatra:${SLOT}"
+ fi
+}