summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:18:26 +0200
commita6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4 (patch)
tree4d3ec8ddaa83500e5b7b78a9fdbb5d4fd20540d5 /kde-apps/dolphin
parentkde-frameworks/kdelibs: 4.14.37 version bump (diff)
downloadgentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.gz
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.bz2
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.zip
kde-apps: Add KDE Applications 17.08.2
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-17.08.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 4a0740727a48..bfa9f952bcce 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-17.04.3.tar.xz 4708604 SHA256 4a987f456f0090bc527333cdbc9e9c41d56e5ca223c7f29839d4a000b99017e1 SHA512 8e7cb264395ff0d0f16727c0979373b1bad79cc94c1878bf31c2004dfba4c259de53f24c19ff975f28308a8876ad1297db133d813ec4aa4d1bd22e7391079cc0 WHIRLPOOL a2f0146a6fe53ddd0ad180acfbe850c2cff74f7d5400a7f49f3c92d00fa2d2403f56e605bd59ea23d7d053239fa37e1c3e567739c98050f7c37df5ebed06252a
DIST dolphin-17.08.1.tar.xz 4831392 SHA256 78e4afe337b17b768fa6e615b2493cfdc2b46731ca127c76ae459b3a00de6911 SHA512 eaba0897016bcf11703ddb561fc9650b280092bca4acc19adfdf2c1105581f38e405c49b39a2bc7ecc17699d5c6ef0771e0e85fc2436555c33b8bc6c539ae226 WHIRLPOOL bf97b969d9bd606b5cf103a6689ec7e0e66644e3b78b92307536805adf2be2dc05e13d51a8c9009e744727331db7080f310a336dbaf9a032be34839ca1fe08d6
+DIST dolphin-17.08.2.tar.xz 4831696 SHA256 3abf212d7e500ec0b41eb60efb83d7e6034e75a3da124ee877231f32c13f7bd4 SHA512 de77ab439243b13952cb8d11343b0bd575b77c0daae7fc3936e91b0de9aed069593fbf97024ec84c7342d2993cfb4b2c64bf18da82cdf362b38e8623954559a2 WHIRLPOOL a2134fff20dc52db21d16d8f5e0c51cc70d43ed2f20232cedd876fc8a787871aee682cb0083f70cb353a8e6095973ece32f30d7298062c4a46f64297a563fe58
diff --git a/kde-apps/dolphin/dolphin-17.08.2.ebuild b/kde-apps/dolphin/dolphin-17.08.2.ebuild
new file mode 100644
index 000000000000..7afe193dc052
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-17.08.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}