summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 15:56:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 16:33:53 +0100
commit6cdf34a3d24d9669ed06751ca16333f0daff21a3 (patch)
treee0363e0204884cc75be55c81760e69788c00e286 /kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild
parentnet-vpn/wireguard-tools: bump to 1.0.20200206 (diff)
downloadgentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.gz
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.bz2
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.zip
kde-apps: Add KDE Release Service 19.12.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild')
-rw-r--r--kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild b/kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild
new file mode 100644
index 000000000000..09b3f69b9554
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-19.12.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+KFMIN=5.63.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://kde.org/applications/system/org.kde.ksystemlog"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp || die
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" \
+ -i ksystemlog/tests/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package systemd Journald)
+ )
+ ecm_src_configure
+}