summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 21:12:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 21:48:16 +0100
commit3e795f7a1b20658a13919a3cd06d07288fa7ed36 (patch)
tree9fcfab9888948baf6e5000c52b380e8654fcbde3 /kde-apps/ktp-call-ui
parentmedia-tv/dtv-scan-tables: Version bump to 0_p20190922 (diff)
downloadgentoo-3e795f7a1b20658a13919a3cd06d07288fa7ed36.tar.gz
gentoo-3e795f7a1b20658a13919a3cd06d07288fa7ed36.tar.bz2
gentoo-3e795f7a1b20658a13919a3cd06d07288fa7ed36.zip
kde-apps/ktp-call-ui: Fix build with net-libs/telepathy-qt-0.9.8
Closes: https://bugs.gentoo.org/701096 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-call-ui')
-rw-r--r--kde-apps/ktp-call-ui/files/ktp-call-ui-19.08.3-telepathy-qt-0.9.8.patch30
-rw-r--r--kde-apps/ktp-call-ui/ktp-call-ui-19.08.3.ebuild12
2 files changed, 37 insertions, 5 deletions
diff --git a/kde-apps/ktp-call-ui/files/ktp-call-ui-19.08.3-telepathy-qt-0.9.8.patch b/kde-apps/ktp-call-ui/files/ktp-call-ui-19.08.3-telepathy-qt-0.9.8.patch
new file mode 100644
index 000000000000..d2be3f480eed
--- /dev/null
+++ b/kde-apps/ktp-call-ui/files/ktp-call-ui-19.08.3-telepathy-qt-0.9.8.patch
@@ -0,0 +1,30 @@
+From 70564e30def5a877bd66e4758a72facf7ff1b09f Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Mon, 18 Nov 2019 22:09:24 +0100
+Subject: Fix build with telepathy-qt 0.9.8
+
+Use the new TelepathyQt5::Farstream link target with 0.9.8, otherwise compilation fails with
+/usr/include/telepathy-qt5/TelepathyQt/_gen/types.h:15:10: fatal error: QDBusArgument: No such file or directory
+
+Differential Revision: https://phabricator.kde.org/D25372
+---
+ libqtf/CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libqtf/CMakeLists.txt b/libqtf/CMakeLists.txt
+index 3025576..3b7b0fe 100644
+--- a/libqtf/CMakeLists.txt
++++ b/libqtf/CMakeLists.txt
+@@ -20,6 +20,10 @@ add_definitions(
+
+ add_library(qtf STATIC qtf.cpp)
+
++if (TARGET TelepathyQt5::Farstream) # telepathy-qt 0.9.8
++ set (TELEPATHY_QT5_FARSTREAM_LIBRARIES TelepathyQt5::Farstream)
++endif()
++
+ target_link_libraries(qtf
+ ${QTGSTREAMER_LIBRARIES}
+ ${TP_FARSTREAM_LDFLAGS}
+--
+cgit v1.1
diff --git a/kde-apps/ktp-call-ui/ktp-call-ui-19.08.3.ebuild b/kde-apps/ktp-call-ui/ktp-call-ui-19.08.3.ebuild
index eda2799c8721..d47d64abb4d0 100644
--- a/kde-apps/ktp-call-ui/ktp-call-ui-19.08.3.ebuild
+++ b/kde-apps/ktp-call-ui/ktp-call-ui-19.08.3.ebuild
@@ -17,6 +17,11 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""
RDEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
@@ -28,11 +33,6 @@ RDEPEND="
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-apps/ktp-common-internals-${PVCUT}:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- dev-libs/glib:2
media-libs/phonon[qt5(+)]
media-libs/qt-gstreamer[qt5(+)]
net-libs/farstream:0.2
@@ -43,3 +43,5 @@ RDEPEND="
DEPEND="${RDEPEND}
>=kde-frameworks/kcmutils-${KFMIN}:5
"
+
+PATCHES=( "${FILESDIR}/${P}-telepathy-qt-0.9.8.patch" ) # bug 701096