summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-14 08:53:59 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-14 08:54:11 +0200
commitd75d62e86e94f72be5c0d39e70046e24310ff0ae (patch)
treeb05f1132b5224b3b1eef6b914e42d1204a4e9551 /kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild
parentkde5.eclass: Prepare for re-use of code w/ kde4-l10n (diff)
downloadgentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.gz
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.bz2
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.zip
kde-apps: Version bump KDE Applications 16.04.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild')
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild
new file mode 100644
index 000000000000..9a9d1c14ff09
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-16.04.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+ !kde-apps/ktp-text-ui:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}