summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/rocs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/rocs')
-rw-r--r--kde-apps/rocs/Manifest1
-rw-r--r--kde-apps/rocs/metadata.xml5
-rw-r--r--kde-apps/rocs/rocs-4.14.3.ebuild38
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/rocs/Manifest b/kde-apps/rocs/Manifest
new file mode 100644
index 000000000000..bb203ab43b23
--- /dev/null
+++ b/kde-apps/rocs/Manifest
@@ -0,0 +1 @@
+DIST rocs-4.14.3.tar.xz 1146328 SHA256 c1dc2ea6b7e1ab0128a28df1f4e09d9bf83c2a1d0d22ff022a86e7f5fb98d4fc SHA512 f0c1d35fcd17473459a3f63ce731c3cf27da51d64b53383f1c4ff280e8df256b80c2797e0c9012cad92601e2155f3e79118a8b8af20af2b3ce10c7ab40ca9d53 WHIRLPOOL 985c58e94999d17f6d96c4b9eafa9fa1e8926001904cfa54600b96e33803336b8b58e9deda01a9923fa6a5f10466294672fbdd7d9de06dd8177a2ebb7cdbcc1f
diff --git a/kde-apps/rocs/metadata.xml b/kde-apps/rocs/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-apps/rocs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-apps/rocs/rocs-4.14.3.ebuild b/kde-apps/rocs/rocs-4.14.3.ebuild
new file mode 100644
index 000000000000..4978f06f510d
--- /dev/null
+++ b/kde-apps/rocs/rocs-4.14.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface to work with Graph Theory"
+HOMEPAGE="http://www.kde.org/applications/education/rocs
+http://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/grantlee:0
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test
+# bug 443752
+
+src_test() {
+ local mycmakeargs=(-DKDE4_BUILD_TESTS=ON)
+ cmake-utils_src_configure
+ kde4-base_src_compile
+
+ cd "${BUILD_DIR}"
+ emake DESTDIR="${T}/tests" install
+ export KDEDIRS="${KDEDIRS}:${T}/tests/${PREFIX}"
+ kbuildsycoca4
+ ctest || die "tests failed"
+}