summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-12-13 19:54:59 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-12-15 00:12:17 +1100
commitb6eb841a21cd2b4e491d69d6d08e6cfadb4dbb2b (patch)
tree424b50887a8ebba33e314b32ce6d4ea7a1005602 /kde-base
parentmedia-video/kamoso: version bump (diff)
downloadgentoo-b6eb841a21cd2b4e491d69d6d08e6cfadb4dbb2b.tar.gz
gentoo-b6eb841a21cd2b4e491d69d6d08e6cfadb4dbb2b.tar.bz2
gentoo-b6eb841a21cd2b4e491d69d6d08e6cfadb4dbb2b.zip
kde-base: Add >=cmake-3.4 configure fix for KDE PIM
See also: https://bugs.gentoo.org/show_bug.cgi?id=566058 Tested-by: Vadim Package-Manager: portage-2.2.24
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmail/files/kdepim-4.14.10-fix-cmake-3.4.patch23
-rw-r--r--kde-base/kmail/kmail-4.14.10.ebuild2
-rw-r--r--kde-base/konsolekalendar/files/kdepim-4.14.10-fix-cmake-3.4.patch23
-rw-r--r--kde-base/konsolekalendar/konsolekalendar-4.14.10.ebuild2
-rw-r--r--kde-base/korganizer/files/kdepim-4.14.10-fix-cmake-3.4.patch23
-rw-r--r--kde-base/korganizer/korganizer-4.14.10.ebuild6
6 files changed, 77 insertions, 2 deletions
diff --git a/kde-base/kmail/files/kdepim-4.14.10-fix-cmake-3.4.patch b/kde-base/kmail/files/kdepim-4.14.10-fix-cmake-3.4.patch
new file mode 100644
index 000000000000..4039cbfcecc4
--- /dev/null
+++ b/kde-base/kmail/files/kdepim-4.14.10-fix-cmake-3.4.patch
@@ -0,0 +1,23 @@
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 13 Dec 2015 09:20:24 +0000
+Subject: Fix configure with >=cmake-3.4
+X-Git-Url: http://quickgit.kde.org/?p=kdepim.git&a=commitdiff&h=91275a772e51a4031b8f34bc83652b5e60478624
+---
+Fix configure with >=cmake-3.4
+
+REVIEW: 126334
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,8 @@
+
+ # where to look first for cmake modules. This line must be the first one or cmake will use the system's FindFoo.cmake
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/modules")
++
++include(CheckIncludeFiles)
+
+ ############### Build Options ###############
+
+
diff --git a/kde-base/kmail/kmail-4.14.10.ebuild b/kde-base/kmail/kmail-4.14.10.ebuild
index 490a793dd42d..df4cbe3efd4d 100644
--- a/kde-base/kmail/kmail-4.14.10.ebuild
+++ b/kde-base/kmail/kmail-4.14.10.ebuild
@@ -74,6 +74,8 @@ KMEXTRA="
KMLOADLIBS="kdepim-common-libs"
+PATCHES=( "${FILESDIR}/kdepim-4.14.10-fix-cmake-3.4.patch" )
+
src_configure() {
# Bug 308903
use ppc64 && append-flags -mminimal-toc
diff --git a/kde-base/konsolekalendar/files/kdepim-4.14.10-fix-cmake-3.4.patch b/kde-base/konsolekalendar/files/kdepim-4.14.10-fix-cmake-3.4.patch
new file mode 100644
index 000000000000..4039cbfcecc4
--- /dev/null
+++ b/kde-base/konsolekalendar/files/kdepim-4.14.10-fix-cmake-3.4.patch
@@ -0,0 +1,23 @@
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 13 Dec 2015 09:20:24 +0000
+Subject: Fix configure with >=cmake-3.4
+X-Git-Url: http://quickgit.kde.org/?p=kdepim.git&a=commitdiff&h=91275a772e51a4031b8f34bc83652b5e60478624
+---
+Fix configure with >=cmake-3.4
+
+REVIEW: 126334
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,8 @@
+
+ # where to look first for cmake modules. This line must be the first one or cmake will use the system's FindFoo.cmake
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/modules")
++
++include(CheckIncludeFiles)
+
+ ############### Build Options ###############
+
+
diff --git a/kde-base/konsolekalendar/konsolekalendar-4.14.10.ebuild b/kde-base/konsolekalendar/konsolekalendar-4.14.10.ebuild
index 8484f8b7212e..bd6743972566 100644
--- a/kde-base/konsolekalendar/konsolekalendar-4.14.10.ebuild
+++ b/kde-base/konsolekalendar/konsolekalendar-4.14.10.ebuild
@@ -46,3 +46,5 @@ KMEXTRACTONLY="
"
KMLOADLIBS="kdepim-common-libs"
+
+PATCHES=( "${FILESDIR}/kdepim-4.14.10-fix-cmake-3.4.patch" )
diff --git a/kde-base/korganizer/files/kdepim-4.14.10-fix-cmake-3.4.patch b/kde-base/korganizer/files/kdepim-4.14.10-fix-cmake-3.4.patch
new file mode 100644
index 000000000000..4039cbfcecc4
--- /dev/null
+++ b/kde-base/korganizer/files/kdepim-4.14.10-fix-cmake-3.4.patch
@@ -0,0 +1,23 @@
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 13 Dec 2015 09:20:24 +0000
+Subject: Fix configure with >=cmake-3.4
+X-Git-Url: http://quickgit.kde.org/?p=kdepim.git&a=commitdiff&h=91275a772e51a4031b8f34bc83652b5e60478624
+---
+Fix configure with >=cmake-3.4
+
+REVIEW: 126334
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,8 @@
+
+ # where to look first for cmake modules. This line must be the first one or cmake will use the system's FindFoo.cmake
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/modules")
++
++include(CheckIncludeFiles)
+
+ ############### Build Options ###############
+
+
diff --git a/kde-base/korganizer/korganizer-4.14.10.ebuild b/kde-base/korganizer/korganizer-4.14.10.ebuild
index d15bdb934f21..1f45e3593c21 100644
--- a/kde-base/korganizer/korganizer-4.14.10.ebuild
+++ b/kde-base/korganizer/korganizer-4.14.10.ebuild
@@ -68,6 +68,8 @@ src_unpack() {
}
src_prepare() {
+ epatch "${FILESDIR}/kdepim-4.14.10-fix-cmake-3.4.patch"
+
use handbook && epatch "${FILESDIR}/${PN}-4.14.10-handbook.patch"
kde4-meta_src_prepare
@@ -76,8 +78,8 @@ src_prepare() {
src_install() {
kde4-meta_src_install
# colliding with kdepim-common-libs
- rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
- rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
+ rm -rf "${ED}"usr/share/kde4/servicetypes/calendarplugin.desktop || die
+ rm -rf "${ED}"usr/share/kde4/servicetypes/calendardecoration.desktop || die
}
pkg_postinst() {