summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 19:41:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 21:28:07 +0200
commit960b53f1cd249091348514ca4d444eb0ba967cfd (patch)
tree44882776b9db1882d72f47230991d1128a38b2d1 /kde-frameworks/frameworkintegration
parentmedia-gfx/kxstitch: 2.2.0 version bump (diff)
downloadgentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.gz
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.bz2
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.zip
kde-frameworks: Add KDE Frameworks 5.59.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.59.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b59d8d738f79..1c0d7445d672 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.57.0.tar.xz 1753224 BLAKE2B 533532e20231e4d1d4bee8d5964c791a62f5d91a4e458b720e7d8086e92204b234846269f3ae6c23492bb77e0d42ae39da6d2dae85a1e034c0bd67be04639b88 SHA512 e8aadd2d4ead08ada18809b0a54879415dbf699885ec74c56dd689226a235fe6a034600a0b357162eee475c8798863ef0b50ea1384c603756b3dbfbf3425df1b
DIST frameworkintegration-5.58.2.tar.xz 1753508 BLAKE2B e8f647b58f87adf2f3bd1813f8bc22c5b87e07ec8020dc07a65de31b970ab048111575f529055e46d3b9601abb250e03e6ebe9c2799ccc057f795e5daf5a7a6f SHA512 ebcb1be8cc103a24d8f76d3f007a9040ec18fad6b65a8c6afbeb51232eb31ddafd903008e1831259f2f5d915f16894c56e384a8ed625c32f172ae6368e3e0e99
+DIST frameworkintegration-5.59.0.tar.xz 1753676 BLAKE2B 08e082a5bb728fb1c3f670a56690d8bb2e7d3a4d77e4e79fc536af24d78243a9a726ea19bf972f46b7b4ab863bb860c67b424283c6340d15ed70b90ae4718c0a SHA512 31aead885ab8834f85c32aa824078e0a4047a4c57f6106345f568b47f2a67af2193166e4cb429310580601589ad046a2a5fcee170cab00ce93abc9f56675fc8c
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.59.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.59.0.ebuild
new file mode 100644
index 000000000000..abb6426a7b47
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.59.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}