summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-08 19:58:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-10 10:14:22 +0200
commit31205c7ce3345b1d07c4d0759e5daecd278871d9 (patch)
treec8d101710c04a67d621272752b0eef1056c826ff /kde-frameworks/kauth
parentkde-frameworks/kactivities: 5.99.0 version bump (diff)
downloadgentoo-31205c7ce3345b1d07c4d0759e5daecd278871d9.tar.gz
gentoo-31205c7ce3345b1d07c4d0759e5daecd278871d9.tar.bz2
gentoo-31205c7ce3345b1d07c4d0759e5daecd278871d9.zip
kde-frameworks/kauth: 5.99.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.99.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 1763c25331f8..1c464da22af1 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.96.0.tar.xz 91188 BLAKE2B 12bb41387cc07b63bb33137746a1482058335505008b5b6759e51b5be1b1426cda55004f1378dee752302dfca73ad3feadd69d20c85ea9d35566e3f222997366 SHA512 ebee1ba35b3dfa439b79c1aab6a51ec968837253e07e913edb4813214744427baffa5d2be661d66f40c7c25b09184dc6dea1773854caede1a263327d9f582204
DIST kauth-5.98.0.tar.xz 91044 BLAKE2B 01071279dd92a11c01e43f8061637b0297cf5f501eda37d0995bf9d3b7629f6016968c75db96293bf3526f405e2a8c5a77327c305ffe07bdb1161f34611ebc24 SHA512 7d5fe4fe79f1d7d9533fd28a7629449fd20927fddea0d72b2f8e41b5b1cc30c9ed3e6b0697f20879ea2eaf258af56194d7bf44816ac91abc56c7d36071f87140
+DIST kauth-5.99.0.tar.xz 91096 BLAKE2B d1451be60487587e327c0ea63f7bb39ac557582f9e272f10ed221232fa9897243ea43b3d8bb52acc8c85c8f769bea30f1cc75bfd7a02dadacda1ef1ce7b28459 SHA512 5d83cb98a952069eb2839e52c163b5de3145eda149b825b8e07919707dc36c90d58cb65c0355043ec5174b3bb4f2eeccd8b0e955bc89cebd69cfd3c5146c8b01
diff --git a/kde-frameworks/kauth/kauth-5.99.0.ebuild b/kde-frameworks/kauth/kauth-5.99.0.ebuild
new file mode 100644
index 000000000000..9253dd27e63a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.99.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}