summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-09-09 13:29:10 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-09 13:29:51 +0200
commit449b70581d8bd53212434c5c5b883099333502de (patch)
treecbfac5508f05db31d1c2b685f4e98d89c5a3ddde /kde-frameworks/kauth
parentx11-misc/compton: Remove desktop-misc maintainership (reverts initial commit). (diff)
downloadgentoo-449b70581d8bd53212434c5c5b883099333502de.tar.gz
gentoo-449b70581d8bd53212434c5c5b883099333502de.tar.bz2
gentoo-449b70581d8bd53212434c5c5b883099333502de.zip
kde-frameworks: Version bump KDE Frameworks 5.38.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.38.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 471286eb37bf..ae94ca43bd71 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.34.0.tar.xz 84248 SHA256 6da4cd885c1fcb474e3b4b46fb7a2ce39ee0a152a84a451f2fd0c673f50a9c19 SHA512 7218e09965e9ea9875d129433534888d8cc1668dd7b7d1be9265d8327d1a167bc3e918a1aba0835bf3edd70d552ad17fc22ffa4fe182c13a08b8304f2e52ad4b WHIRLPOOL 787c355b806f141fa70965ad49c6eeaa9d7c10a5bff5d8818618033bb401f4979def8ddcd66a955ad3695786ffe275fe3f6391c0d852147cb09ef5f6791ba023
DIST kauth-5.37.0.tar.xz 84568 SHA256 bc982bb8443d8a9791c4fffa20e29c9f852a7a18fa31f023d8b4efb517123f32 SHA512 b97956d8360035102c9ba489806720263a0abebc06dac0b9121377030bbc16deff96cbcdfacbd1d91a6d3bd4bc868dab068a5f833bd437669b929315450eb44a WHIRLPOOL 940b682ed172418ee1222cd30be50b8f49d2cae90262beb75678c33f74a572e7c6ac73255c4cd8752aff277eb5ac6a6929644296e8b71e4274603570cbb05c8f
+DIST kauth-5.38.0.tar.xz 84804 SHA256 279af9593b3bf8b2730730877ff865944839e08d21855ea25864934fe372de8a SHA512 00b7e1a5e9149ab0a462571f5fcc60594ef0880772ea9bcb3c5e11f4c976c3de0db8b01ce1cae0639e4176a34fde00b0ab9d5b9b25474b3cbc1945098a49220d WHIRLPOOL be38607a034098be06f44fe568d8c131ceb6087df923f46d5cb19014181d52cd5fc55e6bea6cb5b3c7f0388e034884013257cd090655c115184de1522f637370
diff --git a/kde-frameworks/kauth/kauth-5.38.0.ebuild b/kde-frameworks/kauth/kauth-5.38.0.ebuild
new file mode 100644
index 000000000000..4852c2fb783a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.38.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}