summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-23 11:03:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-23 11:07:57 +0200
commit02bc077693ac56742bb355bc787f006606c7f6fb (patch)
tree5f841986ee508e592328c4a8a86d9e6bc78fa94e /kde-frameworks/kdelibs/files
parentprofiles: arm: Drop obsolete plasmate package.use.mask (diff)
downloadgentoo-02bc077693ac56742bb355bc787f006606c7f6fb.tar.gz
gentoo-02bc077693ac56742bb355bc787f006606c7f6fb.tar.bz2
gentoo-02bc077693ac56742bb355bc787f006606c7f6fb.zip
kde-frameworks/kdelibs: 4.14.34 bump, fix USE=opengl, build w/ cmake-3.9
Drop obsolete pkg_pretend minimum GCC check. Remove Nepomuk headers, nothing should be using them. Gentoo-bug: 504012, 625506 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kdelibs/files')
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.34-cmake-3.9.patch35
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.34-svg.patch35
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.34-cmake-3.9.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.34-cmake-3.9.patch
new file mode 100644
index 000000000000..993b5235a7bd
--- /dev/null
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.34-cmake-3.9.patch
@@ -0,0 +1,35 @@
+From 57eaf65accb8d058644dc8eee7332e0ec0c1952f Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Thu, 20 Jul 2017 20:12:10 +0200
+Subject: [cmake]: De-duplicate "else" to fix build with cmake-3.9
+
+Otherwise it errors out with:
+"CMake Error at kdeui/CMakeLists.txt:316 (else): A duplicate ELSE
+command was found inside an IF block."
+Also adjust the indentation to match the surrounding lines and remove
+the arguments from else() and endif().
+---
+ kdeui/CMakeLists.txt | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/kdeui/CMakeLists.txt b/kdeui/CMakeLists.txt
+index d6ec8b4..cadb52e 100644
+--- a/kdeui/CMakeLists.txt
++++ b/kdeui/CMakeLists.txt
+@@ -311,11 +311,9 @@ if (Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+ FIND_LIBRARY(SECURITY_LIBRARY Security)
+ set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet_mac.cpp util/qosxkeychain.cpp)
+ add_definitions(-DMAC_USE_OSXKEYCHAIN)
+-else(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+- set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
+-else(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+- set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
+-endif(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
++else()
++ set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
++endif()
+
+ if(NOT WINCE)
+ set(kdeui_LIB_SRCS
+--
+cgit v0.11.2
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.34-svg.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.34-svg.patch
new file mode 100644
index 000000000000..48e82331dd8a
--- /dev/null
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.34-svg.patch
@@ -0,0 +1,35 @@
+From 71c3b3f779c815d5b1c0a87e6d09dadefd6b7409 Mon Sep 17 00:00:00 2001
+From: Wolfgang Bauer <wbauer@tmo.at>
+Date: Tue, 11 Jul 2017 14:25:19 +0200
+Subject: Support SVG too
+
+Konqueror's about page doesn't show icons if the breeze icon theme is
+used.
+The reason is that khtml doesn't support SVG images.
+This patch is supposed to fix it by allowing to use Qt's support in that
+case.
+
+This is a backport of commit ed5c039f2d1996545b95a24e9bff4264144f9f6d
+in khtml
+
+FIXED-IN: 4.14.35
+CCBUG: 355872
+---
+ khtml/imload/decoders/qimageioloader.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/khtml/imload/decoders/qimageioloader.cpp b/khtml/imload/decoders/qimageioloader.cpp
+index cecaeaf..7b6025b 100644
+--- a/khtml/imload/decoders/qimageioloader.cpp
++++ b/khtml/imload/decoders/qimageioloader.cpp
+@@ -131,7 +131,7 @@ public:
+ };
+
+ static const char* const positiveList[] = {
+- "BMP", "TIFF", "JP2", "PNM", "EXR", "XBM", "XPM", "ICO", 0
++ "BMP", "TIFF", "JP2", "PNM", "EXR", "XBM", "XPM", "ICO", "SVG", "SVGZ", 0
+ };
+
+ bool isSupportedFormat(QString format) {
+--
+cgit v0.11.2