summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-13 09:52:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-13 20:22:05 +0100
commit71530393be4f056ecda15e92cfb9e5b5490bbd7c (patch)
tree10879e55e8b1aee741b29a4596d9127fec50b1be /kde-frameworks/kdesu/kdesu-5.92.0.ebuild
parentkde-frameworks/kded: 5.92.0 version bump (diff)
downloadgentoo-71530393be4f056ecda15e92cfb9e5b5490bbd7c.tar.gz
gentoo-71530393be4f056ecda15e92cfb9e5b5490bbd7c.tar.bz2
gentoo-71530393be4f056ecda15e92cfb9e5b5490bbd7c.zip
kde-frameworks/kdesu: 5.92.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.92.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.92.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.92.0.ebuild b/kde-frameworks/kdesu/kdesu-5.92.0.ebuild
new file mode 100644
index 000000000000..642ef2c2ee3a
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.92.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}