summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-10 18:45:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-11 22:46:17 +0200
commitdc715614c735fa65331b2ea2d9b16d0f48472fe5 (patch)
tree24d979ea400f98c9844c5aa339e71bbe530afebb /kde-frameworks/kdoctools
parentkde-frameworks/kcrash: 5.84.0 version bump (diff)
downloadgentoo-dc715614c735fa65331b2ea2d9b16d0f48472fe5.tar.gz
gentoo-dc715614c735fa65331b2ea2d9b16d0f48472fe5.tar.bz2
gentoo-dc715614c735fa65331b2ea2d9b16d0f48472fe5.zip
kde-frameworks/kdoctools: 5.84.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdoctools')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.84.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index 8974948de659..230ed09f5e41 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1,2 +1,3 @@
DIST kdoctools-5.82.0.tar.xz 437024 BLAKE2B 6e51452eef36a28af3adae497906ab02429ac57361bf598b347dca7ae0f9df33b7af0ef4c7ecaa5cde1f1021e9a44633013014d2d5a893f319bd8085b732eb65 SHA512 5255b78f1a51a9e2adeb1c6fe113c6555f50eb8af04d3d78c3942f924c071c11c1598245793c68c97eaa3bd1f299b8f9fe7f190da5b720ab7930ed53070f58d3
DIST kdoctools-5.83.0.tar.xz 436976 BLAKE2B cdab2b1172a909f005c4d5ceb2dce778f43aa8b5ed2330b23a7410956d5a3e3ae5f7c85711823e89d26f9494aafbf398c525a1732b95b1f50c20c0dbb2ef2fab SHA512 6b70865c1b8735b4d43c58eed68a2428087b6eb2f4e4c23996d6a1607faef68f1fe897aba34513f55147dac19faa8c5f7f42989f1cec03848212d72afb4f3cb2
+DIST kdoctools-5.84.0.tar.xz 437044 BLAKE2B 6ef70322977660f68668a450d3582e84f2b216ac3a2ce0415868f002b61775c0a10c1b973e703fbcb5d2a36eba5be155d83c334c7e86e00cb0a16320ede3ca04 SHA512 6ac82dd14844e3c1857d566eb0b90bac27fc13275b9e74989da94fd844c6a2cfbd3c7604e1a71ad50cb1f8a9e4e1405c92b12a6d99b4a82b6ee10cab6341ab81
diff --git a/kde-frameworks/kdoctools/kdoctools-5.84.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.84.0.ebuild
new file mode 100644
index 000000000000..3b3ac23b5f35
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.84.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( >=kde-frameworks/ki18n-${PVCUT}:5 )
+"
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ =kde-frameworks/karchive-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package nls KF5I18n)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ ecm_src_test
+}