summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 00:45:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 01:12:13 +0100
commitab025d7059241a0f9d775a518534b78fd6308734 (patch)
treedd2dd5dadb11c9dda2bcfb0e8e51e1620963c1d5 /kde-frameworks/kguiaddons
parentgui-apps/swaylock: drop 1.7.1 (diff)
downloadgentoo-ab025d7059241a0f9d775a518534b78fd6308734.tar.gz
gentoo-ab025d7059241a0f9d775a518534b78fd6308734.tar.bz2
gentoo-ab025d7059241a0f9d775a518534b78fd6308734.zip
kde-frameworks/kguiaddons: Fix clipboard in Wayland session
Upstream commit dcb254dc6b4e5b76e04a5ee8b4db8177aff10d29 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=463199 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=461903 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=463323 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kguiaddons')
-rw-r--r--kde-frameworks/kguiaddons/files/kguiaddons-5.102.0-fix-waylandclipboard.patch47
-rw-r--r--kde-frameworks/kguiaddons/kguiaddons-5.102.0-r1.ebuild47
2 files changed, 94 insertions, 0 deletions
diff --git a/kde-frameworks/kguiaddons/files/kguiaddons-5.102.0-fix-waylandclipboard.patch b/kde-frameworks/kguiaddons/files/kguiaddons-5.102.0-fix-waylandclipboard.patch
new file mode 100644
index 000000000000..e8b157abebec
--- /dev/null
+++ b/kde-frameworks/kguiaddons/files/kguiaddons-5.102.0-fix-waylandclipboard.patch
@@ -0,0 +1,47 @@
+From dcb254dc6b4e5b76e04a5ee8b4db8177aff10d29 Mon Sep 17 00:00:00 2001
+From: David Redondo <kde@david-redondo.de>
+Date: Fri, 27 Jan 2023 13:17:43 +0100
+Subject: [PATCH] waylandclipboard: roundtrip to get accurate focus state
+
+The current approach is too complicated and not correct anyway.
+To summarize QGuiApplication::focusWindow is delayed so the focus
+watcher was introduced, however when the window is hidden and
+setMimeData called before Wayland events have been processed,
+then focusWatcher is naturally out of sync, so the check
+was complicated to work around this state. However the same
+issue arises when the window is deleted before calling
+setMimeData.
+Instead of introducing more complicated checks and workaround
+roundtrip so the focusWatcher state is up to date before setting
+the clipboard.
+BUG:463199
+FIXED-IN: 5.103
+---
+ src/systemclipboard/waylandclipboard.cpp | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/src/systemclipboard/waylandclipboard.cpp b/src/systemclipboard/waylandclipboard.cpp
+index 4c68904..d6c4c08 100644
+--- a/src/systemclipboard/waylandclipboard.cpp
++++ b/src/systemclipboard/waylandclipboard.cpp
+@@ -591,9 +591,14 @@ void WaylandClipboard::setMimeData(QMimeData *mime, QClipboard::Mode mode)
+ if (!m_device) {
+ return;
+ }
+- // If the application is focused, use the normal mechanism so a future paste will not deadlock itself
+- // On enter Qt delays processing of the enter event but when a window is hidden the leave event arrives after hiding the window
+- if (const auto fw = QGuiApplication::focusWindow(); (fw && fw->isVisible()) || (!fw && m_keyboardFocusWatcher->hasFocus())) {
++
++ // roundtrip to have accurate focus state when losing focus but setting mime data before processing wayland events.
++ auto native = qGuiApp->platformNativeInterface();
++ auto display = static_cast<struct ::wl_display *>(native->nativeResourceForIntegration("wl_display"));
++ wl_display_roundtrip(display);
++
++ // If the application is focused, use the normal mechanism so a future paste will not deadlock itselfs
++ if (m_keyboardFocusWatcher->hasFocus()) {
+ QGuiApplication::clipboard()->setMimeData(mime, mode);
+ return;
+ }
+--
+GitLab
+
diff --git a/kde-frameworks/kguiaddons/kguiaddons-5.102.0-r1.ebuild b/kde-frameworks/kguiaddons/kguiaddons-5.102.0-r1.ebuild
new file mode 100644
index 000000000000..5d03529205c3
--- /dev/null
+++ b/kde-frameworks/kguiaddons/kguiaddons-5.102.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI="false"
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing assorted high-level user interface components"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="dbus wayland X"
+
+# slot op: includes qpa/qplatformnativeinterface.h
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ dbus? ( >=dev-qt/qtdbus-${QTMIN}:5 )
+ wayland? (
+ dev-libs/wayland
+ >=dev-qt/qtgui-${QTMIN}:5=[wayland]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ wayland? ( >=dev-libs/plasma-wayland-protocols-1.7.0 )
+ X? ( x11-libs/libxcb )
+"
+BDEPEND="wayland? ( >=dev-qt/qtwaylandscanner-${QTMIN}:5 )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-waylandclipboard.patch" ) # KDE-bug 463199
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_DBUS=$(usex dbus)
+ -DWITH_WAYLAND=$(usex wayland)
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}