summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
commitfc673f93b204709bd56426d01fb497d17a231549 (patch)
treea4e35f1a0c18dd58b04ced4408e79f76c9383ffc /kde-frameworks/ki18n
parentkde-apps/kalarm: Drop bogus COMMON_DEPEND (diff)
downloadgentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.gz
gentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.bz2
gentoo-fc673f93b204709bd56426d01fb497d17a231549.zip
kde-frameworks: Add KDE Frameworks 5.55.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n')
-rw-r--r--kde-frameworks/ki18n/Manifest1
-rw-r--r--kde-frameworks/ki18n/ki18n-5.55.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/Manifest b/kde-frameworks/ki18n/Manifest
index e4651d804bfa..325c9952ec62 100644
--- a/kde-frameworks/ki18n/Manifest
+++ b/kde-frameworks/ki18n/Manifest
@@ -1 +1,2 @@
DIST ki18n-5.54.0.tar.xz 586796 BLAKE2B 8c7846526e3fbd08f0feab8b3726fb92409cebd8b0ef5c84176941d7258f1089e479d76757ca801b997acb7a2c7e98d1603c6880a7ca01b90cc986b73cd21b7d SHA512 1c974a8445cac7474b989b641b154c131f6231d97979d3c54e04b6182b10f87d3412d9e75503ead09499e83d30e2eafeeff9ddd8683fd2005889e675311a5bb6
+DIST ki18n-5.55.0.tar.xz 587224 BLAKE2B 5175d80cee51b4b1c147c407838974533ab7f771729417c4c8db6aa4affb85fba9523f237bb83de17b452833ec4a320d3f3a8a12fe66e639086d53f1f9dbb5eb SHA512 2ecc7493b594e18abccb828bb3d7da63fb5d6f6920829443758ed4745f1a2f5f45852ab71badaaf9109e1daa404ced905135d8a0cda02229e38de6399b3d3cc7
diff --git a/kde-frameworks/ki18n/ki18n-5.55.0.ebuild b/kde-frameworks/ki18n/ki18n-5.55.0.ebuild
new file mode 100644
index 000000000000..b8f9a96aaaf4
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.55.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+DEPEND="${PYTHON_DEPS}
+ $(add_qt_dep qtdeclarative)
+ sys-devel/gettext
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ kde5_src_configure
+}