summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-01-12 21:16:59 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-01-12 21:18:37 +1100
commitd81c8c353fb01aad79273292f101869943177992 (patch)
tree89634606d909607ea40d5d9ab27f93b2a7ab127c /kde-frameworks/kio
parentwww-apps/moodle: version bump to 3.0.2 (diff)
downloadgentoo-d81c8c353fb01aad79273292f101869943177992.tar.gz
gentoo-d81c8c353fb01aad79273292f101869943177992.tar.bz2
gentoo-d81c8c353fb01aad79273292f101869943177992.zip
kde-frameworks: version bump 5.18.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/Manifest1
-rw-r--r--kde-frameworks/kio/files/kio-5.18.0-ftp-timestamps.patch60
-rw-r--r--kde-frameworks/kio/kio-5.18.0.ebuild82
3 files changed, 143 insertions, 0 deletions
diff --git a/kde-frameworks/kio/Manifest b/kde-frameworks/kio/Manifest
index 27714da08333..a44bb286a75f 100644
--- a/kde-frameworks/kio/Manifest
+++ b/kde-frameworks/kio/Manifest
@@ -1,2 +1,3 @@
DIST kio-5.16.0.tar.xz 2865420 SHA256 3b5ee93fe1796091d387b9cabdc768c9d3b111b30cee24da74d9bab9b927a9d6 SHA512 6ae360c0afa07a0682c28392b78a49eb2d12d86ae7a2e3a8aad95c60139960d0582a40dc3ac7349646ca4f886ad3ac44eb9c057b3307d7b32b99f228af559f9d WHIRLPOOL e637db6ef4fd4a580013361a25448ddf1982e0acfedc7488a23cd47b0ccf119f557cd50900dd6ae0b0b15e1731c7b2c6711f9d7079bf76acc40d76bd9bc478b9
DIST kio-5.17.0.tar.xz 2868916 SHA256 1491a8dfe12bef2b5e889a1fa61eab9c4247608db2934bd22a7b0270d714d0b5 SHA512 03d3c68aebb70357cb251bca937f16fa0e1addb4fbf3fa24420aefe4c5b33317ac618685ef92393e45da415338cf0ed43170075c5fc6b42a4d67619ff262bd63 WHIRLPOOL 57a0dcca686d497e2ef9641272ea34676066702ff03bf88c85f3a1ad1d7beffa5d4ac6188fe3c22a9402de21e2624341d49b32b4b6b73a00b3975ea99c66dfb8
+DIST kio-5.18.0.tar.xz 2877312 SHA256 da526bb9b7f02b9670cf6bea54645a89a5b32d008204a4f2253bdd5e74df0f08 SHA512 35a1fbf27b4d0ffdf3297659e2c1a8b9add92d20f1cf6a3adbb79eed36164abc21caa543931ad3be39695f001d250638c091ed398e1776cc6e1fda8c3556d3a0 WHIRLPOOL ad812a7f12b78b00de95d5d41186927c14a37ef431c3adc5a611a5f0d89340c1f63e1bdffe16216a831229b3a995de312744e55245893953b6408ebcaae60883
diff --git a/kde-frameworks/kio/files/kio-5.18.0-ftp-timestamps.patch b/kde-frameworks/kio/files/kio-5.18.0-ftp-timestamps.patch
new file mode 100644
index 000000000000..71a7d8ce248a
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.18.0-ftp-timestamps.patch
@@ -0,0 +1,60 @@
+From: Wolfgang Bauer <wbauer@tmo.at>
+Date: Thu, 07 Jan 2016 12:38:55 +0000
+Subject: [kio_ftp] fix display of file/directory modification time/date
+X-Git-Url: http://quickgit.kde.org/?p=kio.git&a=commitdiff&h=68af1d7e89b7fed136d4cc62b76c1c6ded2d94eb
+---
+[kio_ftp] fix display of file/directory modification time/date
+
+- QDate() treats the year literally (i.e. 90 is really year 90, not
+1990), so subtracting 1900 is wrong.
+- Use QDate::currentDate() instead of QDateTime::currentDateTime(), we
+only need the current date anyway
+- Initialize day, month, and year to the current date instead of 0. In
+the case when no year is mentioned in the server's reply (the year is
+implicit), it wasn't set to the current year at all, so the result was
+either 0 or -1.
+
+BUG: 354597
+FIXED-IN: 5.19.0
+REVIEW: 126659
+---
+
+
+--- a/src/ioslaves/ftp/ftp.cpp
++++ b/src/ioslaves/ftp/ftp.cpp
+@@ -1763,18 +1763,16 @@
+ // Parsing the date is somewhat tricky
+ // Examples : "Oct 6 22:49", "May 13 1999"
+
+- // First get current time - we need the current month and year
+- QDateTime currentTime(QDateTime::currentDateTime());
+- int currentMonth = currentTime.date().month();
++ // First get current date - we need the current month and year
++ QDate currentDate(QDate::currentDate());
++ int currentMonth = currentDate.month();
+ //qDebug() << "Current time :" << asctime( tmptr );
+- // Reset time fields
+- currentTime.setTime(QTime(0, 0, 0));
+- // Get day number (always second field)
+- int day = 0;
+- int month = 0;
+- int year = 0;
++ int day = currentDate.day();
++ int month = currentDate.month();
++ int year = currentDate.year();
+ int minute = 0;
+ int hour = 0;
++ // Get day number (always second field)
+ if (p_date_2) {
+ day = atoi(p_date_2);
+ }
+@@ -1794,7 +1792,7 @@
+
+ // Parse third field
+ if (qstrlen(p_date_3) == 4) { // 4 digits, looks like a year
+- year = atoi(p_date_3) - 1900;
++ year = atoi(p_date_3);
+ } else {
+ // otherwise, the year is implicit
+ // according to man ls, this happens when it is between than 6 months
+
diff --git a/kde-frameworks/kio/kio-5.18.0.ebuild b/kde-frameworks/kio/kio-5.18.0.ebuild
new file mode 100644
index 000000000000..3029dcb5bcee
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.18.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-libs/libxml2
+ dev-libs/libxslt
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ X? ( dev-qt/qtx11extras:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ handbook? ( $(add_frameworks_dep kdoctools) )
+ test? ( sys-libs/zlib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-proto/xproto
+ )
+"
+PDEPEND="
+ $(add_frameworks_dep kded)
+"
+RDEPEND="${COMMON_DEPEND}"
+
+# tests hang
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-ftp-timestamps.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package acl)
+ $(cmake-utils_use_find_package handbook KF5DocTools)
+ $(cmake-utils_use_find_package kerberos GSSAPI)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}