summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-10 12:02:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-10 12:37:31 +0100
commit964f947d6087b2184209da43091179802be48c6a (patch)
tree7d99942aab50c5efd25be274eba9fc954af21aa6 /kde-frameworks/knotifications
parentkde-frameworks: 5.40.0 amd64 stable, bug #639542 (diff)
downloadgentoo-964f947d6087b2184209da43091179802be48c6a.tar.gz
gentoo-964f947d6087b2184209da43091179802be48c6a.tar.bz2
gentoo-964f947d6087b2184209da43091179802be48c6a.zip
kde-frameworks: Drop KDE Frameworks 5.37.0
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/knotifications')
-rw-r--r--kde-frameworks/knotifications/Manifest1
-rw-r--r--kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch101
-rw-r--r--kde-frameworks/knotifications/knotifications-5.37.0-r1.ebuild46
3 files changed, 0 insertions, 148 deletions
diff --git a/kde-frameworks/knotifications/Manifest b/kde-frameworks/knotifications/Manifest
index 972f64c27ee3..4f73d668c9e1 100644
--- a/kde-frameworks/knotifications/Manifest
+++ b/kde-frameworks/knotifications/Manifest
@@ -1,3 +1,2 @@
-DIST knotifications-5.37.0.tar.xz 100004 BLAKE2B 8daf17052f9975ed87c3c61e12b833790f0990d41cd4223ff7d8f485917fef938e3d801d18788b1cfdc06d5ee5ca695b0b8af827f2c4e6546cefd67ca98e39fb SHA512 3b08faf67d705233e98ff5e6cacdb6983134942f1ea5bb8cac43ecfe7b15aac987702cf635dd8dc3e45047e5069bb3fcd39c9745ac4bf414bb33f69336013644
DIST knotifications-5.40.0.tar.xz 99964 BLAKE2B 7ab0dfcca611b28f2f008fa7984a6b7b832ed718d54fd0cbf1b7b810d02ec89bc6f95fb2ffee1d877397ed68abeefdce113a879ad565e8af9cd892aa1fdddba6 SHA512 7fbeff7ce781904ae9d3d57ef439c1d41880558f219465d5b593ee3099d3ce091124067494f5ce9da590ce68ab8f12ac2eda96c59be8d0a767b3edafeb251675
DIST knotifications-5.41.0.tar.xz 99952 BLAKE2B 9046b2225adf52d58502a1a1a11c878f9fec3e473c1a38cf9a7366a97bd6e6d435d46c6eb220b4c340d35e531cc3ab985311ebed906794068401b77518225fb5 SHA512 403adbafd6408bfe8c38afd312ec3b2b4f73d6601a6ea076d309ea7e7e599365cd89dbd5aad2358fb931c1414c22069228dd7991f65dc0adbeda54701f70354d
diff --git a/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch b/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch
deleted file mode 100644
index 2d1ae95af5fb..000000000000
--- a/kde-frameworks/knotifications/files/knotifications-5.34.0-no-block-notification.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 1c97e1d9741fd15962474f47932dd09728dae76b Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Fri, 28 Jul 2017 13:04:50 +0100
-Subject: [PATCH] Don't block starting notification service
-
-Summary:
-We don't need to manually start the DBus service.
-It blocks the calling app, and dbusServiceExists means that we will
-always end up going the DBus route over a popup anyway, so it won't
-do anything useful.
-
-The service (in the plasma case plasma-wait-for-name) will be started
-automatically when we actually send the notification.
-
-Also fix d-dbusServiceExists being cleared to false when the first
-service owner exits.
-
-BUG: 382444
-
-Subscribers: #frameworks
-
-Tags: #frameworks
-
-Differential Revision: https://phabricator.kde.org/D6963
----
- src/notifybypopup.cpp | 28 +++++++++++-----------------
- 1 file changed, 11 insertions(+), 17 deletions(-)
-
-diff --git a/src/notifybypopup.cpp b/src/notifybypopup.cpp
-index 735d52b..4f244e1 100644
---- a/src/notifybypopup.cpp
-+++ b/src/notifybypopup.cpp
-@@ -109,6 +109,9 @@ public:
- * Specifies if DBus Notifications interface exists on session bus
- */
- bool dbusServiceExists;
-+
-+ bool dbusServiceActivatable;
-+
- /**
- * DBus notification daemon capabilities cache.
- * Do not use this variable. Use #popupServerCapabilities() instead.
-@@ -161,6 +164,7 @@ NotifyByPopup::NotifyByPopup(QObject *parent)
- {
- d->animationTimer = 0;
- d->dbusServiceExists = false;
-+ d->dbusServiceActivatable = false;
- d->dbusServiceCapCacheDirty = true;
- d->nextPosition = -1;
-
-@@ -180,32 +184,20 @@ NotifyByPopup::NotifyByPopup(QObject *parent)
- connect(watcher, SIGNAL(serviceOwnerChanged(QString,QString,QString)),
- SLOT(onServiceOwnerChanged(QString,QString,QString)));
-
-+#ifndef Q_WS_WIN
- if (!d->dbusServiceExists) {
-- bool startfdo = false;
--#ifdef Q_WS_WIN
-- startfdo = true;
--#else
- QDBusMessage message = QDBusMessage::createMethodCall(QStringLiteral("org.freedesktop.DBus"),
- QStringLiteral("/org/freedesktop/DBus"),
- QStringLiteral("org.freedesktop.DBus"),
- QStringLiteral("ListActivatableNames"));
--
-- // FIXME - this should be async
- QDBusReply<QStringList> reply = QDBusConnection::sessionBus().call(message);
- if (reply.isValid() && reply.value().contains(dbusServiceName)) {
-- startfdo = true;
-- // We need to set d->dbusServiceExists to true because dbus might be too slow
-- // starting the service and the first call to NotifyByPopup::notify
-- // might not have had the service up, by setting this to true we
-- // guarantee it will still go through dbus and dbus will do the correct
-- // thing and wait for the service to go up
-+ d->dbusServiceActivatable = true;
-+ //if the service is activatable, we can assume it exists even if it is not currently running
- d->dbusServiceExists = true;
- }
--#endif
-- if (startfdo) {
-- QDBusConnection::sessionBus().interface()->startService(dbusServiceName);
-- }
- }
-+#endif
- }
-
-
-@@ -439,7 +431,9 @@ void NotifyByPopup::onServiceOwnerChanged(const QString &serviceName, const QStr
-
- if (newOwner.isEmpty()) {
- d->notificationQueue.clear();
-- d->dbusServiceExists = false;
-+ if (!d->dbusServiceActivatable) {
-+ d->dbusServiceExists = false;
-+ }
- } else if (oldOwner.isEmpty()) {
- d->dbusServiceExists = true;
-
---
-2.13.5
-
diff --git a/kde-frameworks/knotifications/knotifications-5.37.0-r1.ebuild b/kde-frameworks/knotifications/knotifications-5.37.0-r1.ebuild
deleted file mode 100644
index 09709561d7a1..000000000000
--- a/kde-frameworks/knotifications/knotifications-5.37.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="false"
-inherit kde5
-
-DESCRIPTION="Framework for notifying the user of an event"
-LICENSE="LGPL-2.1+"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="dbus nls speech X"
-
-RDEPEND="
- $(add_frameworks_dep kcodecs)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- media-libs/phonon[qt5(+)]
- dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
- speech? ( $(add_qt_dep qtspeech) )
- X? (
- $(add_qt_dep qtx11extras)
- x11-libs/libX11
- x11-libs/libXtst
- )
-"
-DEPEND="${RDEPEND}
- nls? ( $(add_qt_dep linguist-tools) )
- X? ( x11-proto/xproto )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-5.34.0-no-block-notification.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package dbus dbusmenu-qt5)
- $(cmake-utils_use_find_package speech Qt5TextToSpeech)
- $(cmake-utils_use_find_package X X11)
- )
-
- kde5_src_configure
-}