summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:13:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:20:48 +0200
commit4461ffbf581738fbf48fe1ed744ead6885d93dda (patch)
treede205c455262e9f04e26c52e9327ceb1a65ff4b6 /kde-frameworks/kpackage
parentsys-fs/encfs: Drop 1.9.2 and 1.9.4 (diff)
downloadgentoo-4461ffbf581738fbf48fe1ed744ead6885d93dda.tar.gz
gentoo-4461ffbf581738fbf48fe1ed744ead6885d93dda.tar.bz2
gentoo-4461ffbf581738fbf48fe1ed744ead6885d93dda.zip
kde-frameworks: Drop KDE Frameworks 5.57.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpackage')
-rw-r--r--kde-frameworks/kpackage/Manifest1
-rw-r--r--kde-frameworks/kpackage/files/kpackage-5.57.0-runtime-crashfix.patch42
-rw-r--r--kde-frameworks/kpackage/kpackage-5.57.0-r1.ebuild37
3 files changed, 0 insertions, 80 deletions
diff --git a/kde-frameworks/kpackage/Manifest b/kde-frameworks/kpackage/Manifest
index 668b944da1d3..37936430f13e 100644
--- a/kde-frameworks/kpackage/Manifest
+++ b/kde-frameworks/kpackage/Manifest
@@ -1,2 +1 @@
-DIST kpackage-5.57.0.tar.xz 133456 BLAKE2B 72c295fe68a2afb5d93acd411344b3617c0c85286201541088e4afa0fc2bb8c58633c583f5b572b9e9fc4bbfcb55956cc4cf57355cf9271b1f0afe42fc4330f9 SHA512 bd133f60e8a09e1802354118832ad939235570dea7b8eba028d8144366769626b7f8830cc5486ac0791c21523ea06c284ae8b9b08b2d3a526b43e636698ad360
DIST kpackage-5.60.0.tar.xz 132548 BLAKE2B 9c2dc512080305a4dfc3e20a060088eabe0474c66b58755d46dda74aeb5f8330b1c537ac0f3b2779dbf14166cf9c49831db8458886e683463ad8632d05429703 SHA512 afa110d5c4016311b808231aaa2715b5046daf8c7e0088bfaaf50949df252132f468ef96684b55289e37953f1d8891b0b33457aa54096249d4fa41163dab2477
diff --git a/kde-frameworks/kpackage/files/kpackage-5.57.0-runtime-crashfix.patch b/kde-frameworks/kpackage/files/kpackage-5.57.0-runtime-crashfix.patch
deleted file mode 100644
index 5d13d3f8c3a3..000000000000
--- a/kde-frameworks/kpackage/files/kpackage-5.57.0-runtime-crashfix.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From c3e896e02f9a8dc92d6e26cdbc87fe5c6b9cf3bf Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Sun, 14 Apr 2019 19:44:50 +0200
-Subject: Don't use qAsConst over a temporary variable
-
-Summary:
-(will crash because the temporary will be destroyed before being used)
-
-Detected with
- ag -sr qAsConst'\([^)]*\(' .
-
-Test Plan: builds
-
-Reviewers: mlaurent, cfeck, apol
-
-Reviewed By: mlaurent
-
-Subscribers: kde-frameworks-devel
-
-Tags: #frameworks
-
-Differential Revision: https://phabricator.kde.org/D20552
----
- src/kpackage/package.cpp | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp
-index 130eec6..801f1c2 100644
---- a/src/kpackage/package.cpp
-+++ b/src/kpackage/package.cpp
-@@ -429,7 +429,8 @@ QStringList Package::entryList(const QByteArray &key) const
- QStringList list;
- for (const QString &prefix : qAsConst(d->contentsPrefixPaths)) {
- //qCDebug(KPACKAGE_LOG) << " looking in" << prefix;
-- for (const QString &path : qAsConst(it.value().paths)) {
-+ const QStringList paths = it.value().paths;
-+ for (const QString &path : paths) {
- //qCDebug(KPACKAGE_LOG) << " looking in" << path;
- if (it.value().directory) {
- //qCDebug(KPACKAGE_LOG) << "it's a directory, so trying out" << d->path + prefix + path;
---
-cgit v1.1
diff --git a/kde-frameworks/kpackage/kpackage-5.57.0-r1.ebuild b/kde-frameworks/kpackage/kpackage-5.57.0-r1.ebuild
deleted file mode 100644
index 8fb1c225f7e9..000000000000
--- a/kde-frameworks/kpackage/kpackage-5.57.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kde5
-
-DESCRIPTION="Framework to install and load packages of non binary content"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="man"
-
-BDEPEND="
- man? ( $(add_frameworks_dep kdoctools) )
-"
-DEPEND="
- $(add_frameworks_dep karchive)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-runtime-crashfix.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package man KF5DocTools)
- )
-
- kde5_src_configure
-}
-
-src_test() {
- #bug 650214
- local myctestargs=( -E "(plasma-plasmoidpackagetest)" )
- kde5_src_test
-}