summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-30 17:24:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-30 17:24:09 +0100
commit16d166ea8aae5d5f4246c1ef3bdf1fd88b7e3b8d (patch)
tree1b226aab4135ece0ccc6e4bfb45c45a129d61723 /kde-frameworks
parentmedia-video/gpac: Drop 0.6.1-r2 (diff)
downloadgentoo-16d166ea8aae5d5f4246c1ef3bdf1fd88b7e3b8d.tar.gz
gentoo-16d166ea8aae5d5f4246c1ef3bdf1fd88b7e3b8d.tar.bz2
gentoo-16d166ea8aae5d5f4246c1ef3bdf1fd88b7e3b8d.zip
kde-frameworks/ktexteditor: Allow changing the marker size again
Fixes a regression from 5.54.0. KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=403422 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.54.0-allow-change-marker-size.patch78
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-5.54.0-r1.ebuild57
2 files changed, 135 insertions, 0 deletions
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.54.0-allow-change-marker-size.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.54.0-allow-change-marker-size.patch
new file mode 100644
index 000000000000..032fbc99367e
--- /dev/null
+++ b/kde-frameworks/ktexteditor/files/ktexteditor-5.54.0-allow-change-marker-size.patch
@@ -0,0 +1,78 @@
+From 5a6449c3b3d9bbc2b1bc15a5d5b40d7228f3a406 Mon Sep 17 00:00:00 2001
+From: Dominik Haumann <dhaumann@kde.org>
+Date: Wed, 30 Jan 2019 17:16:32 +0100
+Subject: Fix bug 403422: Allow changing the marker size again
+
+This bug was introduced with https://phabricator.kde.org/D17661
+with commit c287d3858fd780f5e139d05e8bb7d4558ccc71b8
+
+FIXED-IN: 5.55
+BUG: 403422
+---
+ src/dialogs/textareaappearanceconfigwidget.ui | 27 +++++++++++++++++++++------
+ 1 file changed, 21 insertions(+), 6 deletions(-)
+
+diff --git a/src/dialogs/textareaappearanceconfigwidget.ui b/src/dialogs/textareaappearanceconfigwidget.ui
+index 02a0d54..cc44a39 100644
+--- a/src/dialogs/textareaappearanceconfigwidget.ui
++++ b/src/dialogs/textareaappearanceconfigwidget.ui
+@@ -185,10 +185,10 @@
+ <string>Size of the visible highlight marker.</string>
+ </property>
+ <property name="minimum">
+- <number>-1</number>
++ <number>1</number>
+ </property>
+ <property name="maximum">
+- <number>-1</number>
++ <number>5</number>
+ </property>
+ <property name="singleStep">
+ <number>1</number>
+@@ -301,6 +301,21 @@ beginning of a file.</string>
+ <header>kcombobox.h</header>
+ </customwidget>
+ </customwidgets>
++ <tabstops>
++ <tabstop>gbWordWrap</tabstop>
++ <tabstop>chkDynWrapAtStaticMarker</tabstop>
++ <tabstop>cmbDynamicWordWrapIndicator</tabstop>
++ <tabstop>sbDynamicWordWrapDepth</tabstop>
++ <tabstop>chkShowTabs</tabstop>
++ <tabstop>chkShowSpaces</tabstop>
++ <tabstop>sliSetMarkerSize</tabstop>
++ <tabstop>chkShowIndentationLines</tabstop>
++ <tabstop>chkShowWholeBracketExpression</tabstop>
++ <tabstop>chkAnimateBracketMatching</tabstop>
++ <tabstop>chkFoldFirstLine</tabstop>
++ <tabstop>chkShowWordCount</tabstop>
++ <tabstop>chkShowLineCount</tabstop>
++ </tabstops>
+ <resources/>
+ <connections>
+ <connection>
+@@ -314,8 +329,8 @@ beginning of a file.</string>
+ <y>7</y>
+ </hint>
+ <hint type="destinationlabel">
+- <x>340</x>
+- <y>44</y>
++ <x>559</x>
++ <y>117</y>
+ </hint>
+ </hints>
+ </connection>
+@@ -330,8 +345,8 @@ beginning of a file.</string>
+ <y>6</y>
+ </hint>
+ <hint type="destinationlabel">
+- <x>385</x>
+- <y>72</y>
++ <x>559</x>
++ <y>162</y>
+ </hint>
+ </hints>
+ </connection>
+--
+cgit v1.1
+
diff --git a/kde-frameworks/ktexteditor/ktexteditor-5.54.0-r1.ebuild b/kde-frameworks/ktexteditor/ktexteditor-5.54.0-r1.ebuild
new file mode 100644
index 000000000000..72fcd5e12613
--- /dev/null
+++ b/kde-frameworks/ktexteditor/ktexteditor-5.54.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing a full text editor component"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="editorconfig git"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ editorconfig? ( app-text/editorconfig-core-c )
+ git? ( dev-libs/libgit2:= )
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_frameworks_dep kservice) )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-allow-change-marker-size.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package editorconfig EditorConfig)
+ $(cmake-utils_use_find_package git LibGit2)
+ )
+
+ kde5_src_configure
+}