summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-06 14:14:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-11 16:23:01 +0200
commit25fd1ca56880da4943d1811eb51f9e1ff9bb0235 (patch)
tree4d6b28d9225f5a5c5cd3345f0aa5fd7a9f20262e /kde-frameworks
parentkde-frameworks/kio: drop 5.77.0* (diff)
downloadgentoo-25fd1ca56880da4943d1811eb51f9e1ff9bb0235.tar.gz
gentoo-25fd1ca56880da4943d1811eb51f9e1ff9bb0235.tar.bz2
gentoo-25fd1ca56880da4943d1811eb51f9e1ff9bb0235.zip
kde-frameworks/knewstuff: drop 5.77.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/knewstuff/Manifest1
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-5.77.0-add-dptr-to-cache.patch135
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.77.0-r1.ebuild42
3 files changed, 0 insertions, 178 deletions
diff --git a/kde-frameworks/knewstuff/Manifest b/kde-frameworks/knewstuff/Manifest
index 69bc4787abb6..9cb17ac798f8 100644
--- a/kde-frameworks/knewstuff/Manifest
+++ b/kde-frameworks/knewstuff/Manifest
@@ -1,3 +1,2 @@
-DIST knewstuff-5.77.0.tar.xz 1143780 BLAKE2B 72b1e040041e6aca1593700a5378ca88be8b9edc3f2682c433231ee07fed5f56cea749f34dec74835cbc2cf5455e879296d388a0deed5132a9cdedb59ece85e1 SHA512 408b3dd045f13050a41389b4864888f8d261ecade50b4d3903f0982194a0a15828e459e755a001a5593cf818894cca2203ded9cc3fcdd60e23820a1d0f7c45b7
DIST knewstuff-5.80.0.tar.xz 1162316 BLAKE2B b6ceb6106577b52c49ac34f87a8443dd899460e32bcdcd4cc56c5f786c0e7bdfd871e1157da215cc9b7b0dfca8bb29abab6fa212e6ff30b29dc930b5a4c4b4fc SHA512 bd0c601bcfda8f4674392010c863871e511abd97c1e2971ac93bb902e2bf2e5eb925d2b64119473a182944fe91fee3d1e5a7ebe23edc58aad20e2d04a190bc3c
DIST knewstuff-5.81.0.tar.xz 1167932 BLAKE2B 30e214c23455bbfd37e580c266ffbcbf9e54cd6dd36abb1521c1e50cb452252a175e6d802ad62bfa0168b7adccbbd91ff752543b5db78337e38a822df89feec7 SHA512 e00b502b3bbfca177929ec9b7b6108188cc3c3ab5201dfde5af3c5bbca59818430099dd0ff59d450de22bd029081b4f6f7ab2c9366dbb9c3f9485b03235c03a8
diff --git a/kde-frameworks/knewstuff/files/knewstuff-5.77.0-add-dptr-to-cache.patch b/kde-frameworks/knewstuff/files/knewstuff-5.77.0-add-dptr-to-cache.patch
deleted file mode 100644
index f6547fc6e5ff..000000000000
--- a/kde-frameworks/knewstuff/files/knewstuff-5.77.0-add-dptr-to-cache.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-From 243ea6155b28457c8b1441fee8ab1037828d21ba Mon Sep 17 00:00:00 2001
-From: Dan Leinir Turthra Jensen <admin@leinir.dk>
-Date: Mon, 14 Dec 2020 21:11:51 +0000
-Subject: [PATCH] Add a dptr to Cache, and move the throttle timer there to fix
- crash
-
-Previously, the throttle timer was a raw static, but it was also a parented qobject, which means that when the cache was deleted, so was the timer, but the variable was not reset. Consequently, things would crash left and right later on. So, to alleviate this, and hopefully avoid future issues, introduce a dptr, stick the timer there, and move the logic to that private class as well.
-
-BUG:429442
-
-FIXED-IN:5.78
----
- src/core/cache.cpp | 41 ++++++++++++++++++++++++++++++-----------
- src/core/cache.h | 7 +++++--
- 2 files changed, 35 insertions(+), 13 deletions(-)
-
-diff --git a/src/core/cache.cpp b/src/core/cache.cpp
-index 0395045c..ace7be4e 100644
---- a/src/core/cache.cpp
-+++ b/src/core/cache.cpp
-@@ -11,17 +11,42 @@
- #include <QDir>
- #include <QFileInfo>
- #include <QFileSystemWatcher>
-+#include <QPointer>
- #include <QTimer>
- #include <QXmlStreamReader>
- #include <qstandardpaths.h>
- #include <knewstuffcore_debug.h>
-
-+class KNSCore::CachePrivate {
-+public:
-+ CachePrivate(Cache* qq)
-+ : q(qq)
-+ {}
-+ ~CachePrivate() {}
-+
-+ Cache* q;
-+ QHash<QString, EntryInternal::List> requestCache;
-+
-+ QPointer<QTimer> throttleTimer;
-+ void throttleWrite() {
-+ if (!throttleTimer) {
-+ throttleTimer = new QTimer(q);
-+ QObject::connect(throttleTimer, &QTimer::timeout, q, [this](){ q->writeRegistry(); });
-+ throttleTimer->setSingleShot(true);
-+ throttleTimer->setInterval(1000);
-+ }
-+ throttleTimer->start();
-+ }
-+};
-+
- using namespace KNSCore;
-
- typedef QHash<QString, QWeakPointer<Cache> > CacheHash;
- Q_GLOBAL_STATIC(CacheHash, s_caches)
-
--Cache::Cache(const QString &appName): QObject(nullptr)
-+Cache::Cache(const QString &appName)
-+ : QObject(nullptr)
-+ , d(new CachePrivate(this))
- {
- m_kns2ComponentName = appName;
-
-@@ -280,36 +305,30 @@ void Cache::registerChangedEntry(const KNSCore::EntryInternal &entry)
- if (entry.status() == KNS3::Entry::Updating || entry.status() == KNS3::Entry::Installing) {
- return;
- }
-- static QTimer* writeThrottle{nullptr};
-- if (!writeThrottle) {
-- writeThrottle = new QTimer(this);
-- connect(writeThrottle, &QTimer::timeout, this, [this](){ writeRegistry(); });
-- writeThrottle->setInterval(1000);
-- }
- if (!property("reloadingRegistry").toBool()) {
- setProperty("dirty", true);
- cache.remove(entry); // If value already exists in the set, the set is left unchanged
- cache.insert(entry);
-- writeThrottle->start();
-+ d->throttleWrite();
- }
- }
-
- void Cache::insertRequest(const KNSCore::Provider::SearchRequest &request, const KNSCore::EntryInternal::List &entries)
- {
- // append new entries
-- auto &cacheList = requestCache[request.hashForRequest()];
-+ auto &cacheList = d->requestCache[request.hashForRequest()];
- for (const auto &entry : entries) {
- if (!cacheList.contains(entry)) {
- cacheList.append(entry);
- }
- }
-- qCDebug(KNEWSTUFFCORE) << request.hashForRequest() << " add: " << entries.size() << " keys: " << requestCache.keys();
-+ qCDebug(KNEWSTUFFCORE) << request.hashForRequest() << " add: " << entries.size() << " keys: " << d->requestCache.keys();
- }
-
- EntryInternal::List Cache::requestFromCache(const KNSCore::Provider::SearchRequest &request)
- {
- qCDebug(KNEWSTUFFCORE) << request.hashForRequest();
-- return requestCache.value(request.hashForRequest());
-+ return d->requestCache.value(request.hashForRequest());
- }
-
- void KNSCore::Cache::removeDeletedEntries()
-diff --git a/src/core/cache.h b/src/core/cache.h
-index 06e95ab4..73ea7c61 100644
---- a/src/core/cache.h
-+++ b/src/core/cache.h
-@@ -16,9 +16,11 @@
-
- #include "knewstuffcore_export.h"
-
-+#include <memory.h>
-+
- namespace KNSCore
- {
--
-+class CachePrivate;
- class KNEWSTUFFCORE_EXPORT Cache : public QObject
- {
- Q_OBJECT
-@@ -99,7 +101,8 @@ private:
- QString m_kns2ComponentName;
-
- QSet<EntryInternal> cache;
-- QHash<QString, EntryInternal::List> requestCache;
-+
-+ std::unique_ptr<CachePrivate> d;
- };
-
- }
---
-GitLab
-
diff --git a/kde-frameworks/knewstuff/knewstuff-5.77.0-r1.ebuild b/kde-frameworks/knewstuff/knewstuff-5.77.0-r1.ebuild
deleted file mode 100644
index 0f453351949f..000000000000
--- a/kde-frameworks/knewstuff/knewstuff-5.77.0-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_TEST="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.1
-inherit ecm kde.org
-
-DESCRIPTION="Framework for downloading and sharing additional application data"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE=""
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/attica-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
-"
-RDEPEND="${DEPEND}
- >=kde-frameworks/kirigami-${PVCUT}:5
-"
-
-PATCHES=( "${FILESDIR}/${P}-add-dptr-to-cache.patch" ) # KDE-bug 429442