summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-14 23:06:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-15 19:46:49 +0200
commit3e6dcb8a38f69cf8edad355295a2aed5e477f869 (patch)
treed00f2facb93e24c2e1a952a30d7b3709f0b497af /kde-frameworks
parentcmake.eclass: Set CMAKE_COMPILE_WARNING_AS_ERROR=OFF (diff)
downloadgentoo-3e6dcb8a38f69cf8edad355295a2aed5e477f869.tar.gz
gentoo-3e6dcb8a38f69cf8edad355295a2aed5e477f869.tar.bz2
gentoo-3e6dcb8a38f69cf8edad355295a2aed5e477f869.zip
kde-frameworks/extra-cmake-modules: More silence, less appstream test
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.5.0-r1.ebuild72
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-appstreamtest.patch31
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch31
3 files changed, 134 insertions, 0 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.5.0-r1.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.5.0-r1.ebuild
new file mode 100644
index 000000000000..cfe32a36a87c
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-6.5.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+QTMIN=6.6.2
+inherit cmake frameworks.kde.org python-any-r1
+
+DESCRIPTION="Extra modules and scripts for CMake"
+HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/libarchive[bzip2]"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ >=dev-qt/qttools-${QTMIN}:6[assistant]
+ )
+ test? (
+ >=dev-qt/qttools-${QTMIN}:6[linguist]
+ >=dev-qt/qtbase-${QTMIN}:6
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
+ "${FILESDIR}/${PN}-5.93.0-skip-ecm_add_test-early.patch"
+ "${FILESDIR}/${PN}-5.112.0-disable-tests-requiring-PyQt5.patch" # bug 680256
+ "${FILESDIR}/${PN}-5.245.0-disable-qmlplugindump.patch"
+ "${FILESDIR}/${PN}-6.5.0-disable-appstreamtest.patch"
+ "${FILESDIR}/${PN}-6.5.0-disable-git-commit-hooks.patch"
+)
+
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
+ -DBUILD_QTHELP_DOCS=$(usex doc)
+ -DBUILD_HTML_DOCS=$(usex doc)
+ -DBUILD_MAN_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # passes, but then breaks src_install
+ ECMToolchainAndroidTest
+ # broken, bug #627806
+ ECMPoQmToolsTest
+ # can not possibly succeed in releases, bug #764953
+ KDEFetchTranslations
+ )
+ # possible race condition with multiple jobs, bug #701854
+ cmake_src_test -j1
+}
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-appstreamtest.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-appstreamtest.patch
new file mode 100644
index 000000000000..3691e891892b
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-appstreamtest.patch
@@ -0,0 +1,31 @@
+From c287bae2677f0339d12a12f90147b5d96cdaa7a1 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 13 Aug 2024 21:44:24 +0200
+Subject: [PATCH] KDECMakeSettings.cmake: Add ECM_DISABLE_APPSTREAMTEST to not
+ run test
+
+and spend time in every consumer.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ kde-modules/KDECMakeSettings.cmake | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/kde-modules/KDECMakeSettings.cmake b/kde-modules/KDECMakeSettings.cmake
+index 3e4ac32f..9f73eb28 100644
+--- a/kde-modules/KDECMakeSettings.cmake
++++ b/kde-modules/KDECMakeSettings.cmake
+@@ -184,7 +184,10 @@ if(NOT KDE_SKIP_TEST_SETTINGS)
+ option(BUILD_TESTING "Build the testing tree." ON)
+ if(BUILD_TESTING)
+ enable_testing()
++option (ECM_DISABLE_APPSTREAMTEST "Do not run appstreamtest" OFF)
++if(NOT ECM_DISABLE_APPSTREAMTEST)
+ appstreamtest()
++endif()
+ endif ()
+ endif ()
+
+--
+2.45.2
+
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch
new file mode 100644
index 000000000000..ad67e8233a4b
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch
@@ -0,0 +1,31 @@
+From ed944c8c85822c39dea66afdd1759dec093fd6b3 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 13 Aug 2024 22:15:40 +0200
+Subject: [PATCH] KDEGitCommitHooks.cmake: Add ECM_DISABLE_GIT to silence
+ useless Git search/hooks
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ kde-modules/KDEGitCommitHooks.cmake | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/kde-modules/KDEGitCommitHooks.cmake b/kde-modules/KDEGitCommitHooks.cmake
+index 6122cc7a..fef735a2 100644
+--- a/kde-modules/KDEGitCommitHooks.cmake
++++ b/kde-modules/KDEGitCommitHooks.cmake
+@@ -59,7 +59,12 @@ set(GIT_DIR "${CMAKE_SOURCE_DIR}/.git")
+ set(GIT_HOOKS_DIR "${GIT_DIR}/hooks")
+ set(JSON_SCHEMA_OUT "${GIT_HOOKS_DIR}/scripts/combined.schema.json")
+
++option (ECM_DISABLE_GIT "Disable Git commit hooks (for e.g. distro package build)" OFF)
++
+ function(KDE_CONFIGURE_GIT_PRE_COMMIT_HOOK)
++ if(ECM_DISABLE_GIT)
++ return()
++ endif()
+ set(_oneValueArgs "")
+ set(_multiValueArgs CHECKS CUSTOM_SCRIPTS)
+ cmake_parse_arguments(ARG "" "${_oneValueArgs}" "${_multiValueArgs}" ${ARGN})
+--
+2.45.2
+