summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-19 16:35:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-19 17:11:02 +0200
commit67d499adf251b714d9ff7d10a871447d60ca8b96 (patch)
tree311270192a20fa0fc8944cc84caccde44778a075 /kde-frameworks
parentkde-frameworks/plasma: 5.111.0 version bump (diff)
downloadgentoo-67d499adf251b714d9ff7d10a871447d60ca8b96.tar.gz
gentoo-67d499adf251b714d9ff7d10a871447d60ca8b96.tar.bz2
gentoo-67d499adf251b714d9ff7d10a871447d60ca8b96.zip
kde-frameworks/purpose: 5.111.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.111.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index f939cb499ab1..de2b4a0a41ef 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1 +1,2 @@
DIST purpose-5.110.0.tar.xz 180760 BLAKE2B 2bc4c11cd02fc542b9bb1ceff7539d506640c2b46e0ba9e085260067a86418ee31af14ad688025ce687225218c3fa51b8d34400e5e31e3e9faa59cf6db04ffd3 SHA512 b447abfb9a3db5929e7217025173d9316a8414ce3d23553a5049fda8d07a2b77d15a0bee669d089ad6e6e034c41e8671bf83b9ad0de7a17e57c2cfb34cabac30
+DIST purpose-5.111.0.tar.xz 180796 BLAKE2B cb4d94f9877055d62f0ebe7b7d151308b49ced843da2541f81ae29431310af505ef29cf7826416986da20a6060911508ef5e5b0a9e2487a32259bb68f4f15242 SHA512 c05898bc68c6ff7bdd8814203ad6d64f6c7c1346e871a2ef298a660e56b9b2c86a647cc13533626eaad21cc8e238714e1ce03f5ef556a04005140a2d4bba8aa4
diff --git a/kde-frameworks/purpose/purpose-5.111.0.ebuild b/kde-frameworks/purpose/purpose-5.111.0.ebuild
new file mode 100644
index 000000000000..f43120abdffa
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.111.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}