summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-16 10:54:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-18 10:25:48 +0200
commit780a9030595aeab19f2d4cd55e62c81155d25f7e (patch)
tree1bba1ad2501c06225def800690ad1e932a0436b8 /kde-frameworks
parentkde-frameworks/plasma: 5.109.0 version bump (diff)
downloadgentoo-780a9030595aeab19f2d4cd55e62c81155d25f7e.tar.gz
gentoo-780a9030595aeab19f2d4cd55e62c81155d25f7e.tar.bz2
gentoo-780a9030595aeab19f2d4cd55e62c81155d25f7e.zip
kde-frameworks/purpose: 5.109.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.109.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 7b8251e80417..e8374e58c945 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1 +1,2 @@
DIST purpose-5.108.0.tar.xz 179400 BLAKE2B 7678abe3996006acca028d300457550a667ffac743ce163009af87c9b950b159a56453dc1afe3adfb88f9a9cd8710ada7f645fdcf63da7cdb93777883166cb88 SHA512 4dd031ea685c54d06b06ad8ff24d6b7ddd68e5bf27391817889dd0cb377ebdbb8ea6e030bf215e9c93e29b61e7bd62e17ad576e6f8a4189278f6b99e47f02409
+DIST purpose-5.109.0.tar.xz 180772 BLAKE2B 893a560c8fb85a4ca7400ec6dd365d94f186f491d3656a2e0a972d995d9a0f6891d99351e68f214f9ab4268db135585b80febdec56457562b323e5c0a6008f8b SHA512 432733c048ba6c4cb4c148f0043538447d4a82fed06b4158b84d222ce573cec9777f2313a1f17b4a771e9f112260cad8dd0c2e178f751723ba9eacc87703009b
diff --git a/kde-frameworks/purpose/purpose-5.109.0.ebuild b/kde-frameworks/purpose/purpose-5.109.0.ebuild
new file mode 100644
index 000000000000..5476699558c1
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.109.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}