summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/stock-quote
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/stock-quote')
-rw-r--r--kde-misc/stock-quote/Manifest1
-rw-r--r--kde-misc/stock-quote/metadata.xml5
-rw-r--r--kde-misc/stock-quote/stock-quote-2.1-r2.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/kde-misc/stock-quote/Manifest b/kde-misc/stock-quote/Manifest
new file mode 100644
index 000000000000..3729a57b4ed6
--- /dev/null
+++ b/kde-misc/stock-quote/Manifest
@@ -0,0 +1 @@
+DIST 90695-plasma_stock_quote-2.1.tar.bz2 13043 SHA256 1f19def33d9c4ef80e0e25d204c05fa427b7dd25168b9b410009a6e86fd39dd7 SHA512 f11c432d4d033d1eb5a03bf372b306a90bed82c64382d30d6a45ffd474f46273dff1434f9ce7fa85007e44ed5dc5852c14fbffd7b112508f39af752c1b922782 WHIRLPOOL d1ec0603fdc2fce55e64ff36ae3d6a59b4038aee9f36edb9a2c6dcbcae26f68ec8978d20476e2870a434ad40b65d3e0051786b1a48706412414d4c9cc6c1e02f
diff --git a/kde-misc/stock-quote/metadata.xml b/kde-misc/stock-quote/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/stock-quote/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild b/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild
new file mode 100644
index 000000000000..5bb2ee7bbb75
--- /dev/null
+++ b/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+MY_P=plasma_${PN/-/_}-${PV}
+
+DESCRIPTION="Displays stock quotes pulled from the Yahoo! servers"
+HOMEPAGE="http://www.kde-look.org/content/show.php/Stock+Quote?content=90695"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/90695-${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( CHANGELOG README )
+
+src_prepare() {
+ sed -e 's:^[ \t]*::' \
+ -i applet/plasma-applet-stock-quote.desktop || die "fixing .desktop file failed"
+ sed -e 's:^[ \t]*::' \
+ -i dataengine/plasma-dataengine-stockquote.desktop || die "fixing .desktop file failed"
+ kde4-base_src_prepare
+}