summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/synaptiks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/synaptiks')
-rw-r--r--kde-misc/synaptiks/Manifest1
-rw-r--r--kde-misc/synaptiks/files/synaptiks-0.8.1-removedfeatures.patch200
-rw-r--r--kde-misc/synaptiks/files/synaptiks-0.8.1-templatesfix.patch48
-rw-r--r--kde-misc/synaptiks/metadata.xml8
-rw-r--r--kde-misc/synaptiks/synaptiks-0.8.1-r4.ebuild60
5 files changed, 317 insertions, 0 deletions
diff --git a/kde-misc/synaptiks/Manifest b/kde-misc/synaptiks/Manifest
new file mode 100644
index 000000000000..92a8fa77265d
--- /dev/null
+++ b/kde-misc/synaptiks/Manifest
@@ -0,0 +1 @@
+DIST synaptiks-0.8.1.tar.bz2 463495 SHA256 39bbafa6abd63903ba6f9ffd020ec754250ab7800ea9efcdeeebd69c0fcd5707 SHA512 a01b9833b2fb7af699eba015517ac652e4d0df9f46154097a26e57f0c4dc4467db1ceeea52c5f5ee5794b821870356d1d16e9da6aeaa845fc3d7bde10b85d053 WHIRLPOOL da9891f1b29ab174759efae779f08dea31e9a6b266b0d10ee60fa460e588c8620e2fa91a7eafddbd4ead3f9db7e365580bd34db66ea611b2c448590d09c47efd
diff --git a/kde-misc/synaptiks/files/synaptiks-0.8.1-removedfeatures.patch b/kde-misc/synaptiks/files/synaptiks-0.8.1-removedfeatures.patch
new file mode 100644
index 000000000000..4f9fe7c0f094
--- /dev/null
+++ b/kde-misc/synaptiks/files/synaptiks-0.8.1-removedfeatures.patch
@@ -0,0 +1,200 @@
+--- a/doc/api/touchpad.rst
++++ b/doc/api/touchpad.rst
+@@ -27,8 +27,6 @@ The touchpad class
+
+ .. autoattribute:: acceleration_factor
+
+- .. autoattribute:: edge_motion_always
+-
+ .. rubric:: scrolling properties
+
+ .. autoattribute:: vertical_edge_scrolling
+@@ -55,8 +53,6 @@ The touchpad class
+
+ .. rubric:: tapping properties
+
+- .. autoattribute:: fast_taps
+-
+ .. autoattribute:: rt_tap_action
+
+ .. autoattribute:: rb_tap_action
+--- a/doc/handbook/reference.rst
++++ b/doc/handbook/reference.rst
+@@ -69,13 +69,6 @@ The touchpad configuration module is available in |systemsettings| under
+ The acceleration between :guilabel:`Minimum speed` and :guilabel:`Maximum
+ speed`
+
+-:guilabel:`Continue cursor motion when hitting the touchpad edge`
+- Continue the cursor move while the finger stays in the touchpad edge
+-
+- :guilabel:`For all movements, not only dragging`
+- Always continue cursor movement, when hitting the touchpad edge, not only
+- when dragging
+-
+
+ .. _commands-scrolling-configuration:
+
+@@ -152,13 +145,6 @@ The touchpad configuration module is available in |systemsettings| under
+
+ Screenshot of the tapping configuration page
+
+-:guilabel:`General tapping settings`
+-
+- :guilabel:`Make single taps faster and double taps slower (fast taps)`
+- Enable or disable fast taps. If fast taps are enabled, the driver will
+- react faster on single taps, but slower on double clicks caused by double
+- taps.
+-
+ :guilabel:`Mouse clicks triggered by tapping`
+ :guilabel:`Top left corner`
+ Configure the mouse button, which is triggered by tapping the top left
+--- a/doc/handbook/usage.rst
++++ b/doc/handbook/usage.rst
+@@ -41,12 +41,6 @@ though the touchpad does not actually have one. In this case, the middle mouse
+ button is triggered by pressing the left mouse button and the right mouse
+ button at the same time.
+
+-Some systems have a circular touchpad. Unfortunately the touchpad driver does
+-not detect circular touchpad automatically, so if you have a circular touchpad,
+-please enable :guilabel:`The touchpad is circular` to let the driver know, that
+-your touchpad is circular.
+-
+-
+ .. _motion-configuration:
+
+ Motion configuration
+--- a/synaptiks/config.py
++++ b/synaptiks/config.py
+@@ -173,7 +173,6 @@ class TouchpadConfiguration(MutableMapping):
+
+ CONFIG_KEYS = frozenset([
+ 'minimum_speed', 'maximum_speed', 'acceleration_factor',
+- 'edge_motion_always', 'fast_taps',
+ 'rt_tap_action', 'rb_tap_action', 'lt_tap_action', 'lb_tap_action',
+ 'f1_tap_action', 'f2_tap_action', 'f3_tap_action',
+ 'tap_and_drag_gesture', 'locked_drags', 'locked_drags_timeout',
+@@ -182,7 +181,7 @@ class TouchpadConfiguration(MutableMapping):
+ 'vertical_scrolling_distance', 'horizontal_scrolling_distance',
+ 'vertical_two_finger_scrolling', 'horizontal_two_finger_scrolling',
+ 'circular_scrolling', 'circular_scrolling_trigger',
+- 'circular_scrolling_distance', 'circular_touchpad'])
++ 'circular_scrolling_distance'])
+
+ @classmethod
+ def load(cls, touchpad, filename=None):
+--- a/synaptiks/kde/widgets/ui/hardwarepage.ui
++++ b/synaptiks/kde/widgets/ui/hardwarepage.ui
+@@ -27,32 +27,6 @@
+ </widget>
+ </item>
+ <item>
+- <widget class="QGroupBox" name="groupBox">
+- <property name="title">
+- <string>Hardware settings</string>
+- </property>
+- <layout class="QVBoxLayout" name="verticalLayout_2">
+- <item>
+- <widget class="QLabel" name="label_2">
+- <property name="text">
+- <string comment="@info">Please enable this setting, if your touchpad is circular.</string>
+- </property>
+- <property name="wordWrap">
+- <bool>true</bool>
+- </property>
+- </widget>
+- </item>
+- <item>
+- <widget class="QCheckBox" name="touchpad_circular_touchpad">
+- <property name="text">
+- <string comment="@option:check">The touchpad is circular</string>
+- </property>
+- </widget>
+- </item>
+- </layout>
+- </widget>
+- </item>
+- <item>
+ <spacer name="verticalSpacer">
+ <property name="orientation">
+ <enum>Qt::Vertical</enum>
+--- a/synaptiks/kde/widgets/ui/motionpage.ui
++++ b/synaptiks/kde/widgets/ui/motionpage.ui
+@@ -81,22 +81,6 @@
+ </widget>
+ </item>
+ <item>
+- <widget class="QGroupBox" name="edgeMotionGroup">
+- <property name="title">
+- <string comment="@title:group">Continue cursor motion when hitting the touchpad edge</string>
+- </property>
+- <layout class="QVBoxLayout" name="verticalLayout_3">
+- <item>
+- <widget class="QCheckBox" name="touchpad_edge_motion_always">
+- <property name="text">
+- <string comment="@option:radio">For all movements, not only dragging</string>
+- </property>
+- </widget>
+- </item>
+- </layout>
+- </widget>
+- </item>
+- <item>
+ <spacer name="verticalSpacer">
+ <property name="orientation">
+ <enum>Qt::Vertical</enum>
+diff --git a/synaptiks/kde/widgets/ui/tappingpage.ui b/synaptiks/kde/widgets/ui/tappingpage.ui
+index 8d92c2c..89ca751 100644
+--- a/synaptiks/kde/widgets/ui/tappingpage.ui
++++ b/synaptiks/kde/widgets/ui/tappingpage.ui
+@@ -15,22 +15,6 @@
+ </property>
+ <layout class="QVBoxLayout" name="verticalLayout_2">
+ <item>
+- <widget class="QGroupBox" name="generalSettingsGroup">
+- <property name="title">
+- <string comment="@title:group">General tapping settings</string>
+- </property>
+- <layout class="QVBoxLayout" name="verticalLayout_4">
+- <item>
+- <widget class="QCheckBox" name="touchpad_fast_taps">
+- <property name="text">
+- <string comment="@option:check">Make single taps faster and double taps slower (fast taps)</string>
+- </property>
+- </widget>
+- </item>
+- </layout>
+- </widget>
+- </item>
+- <item>
+ <widget class="QGroupBox" name="tappingButtonGroup">
+ <property name="title">
+ <string comment="@title:group">Mouse clicks triggered by tapping</string>
+--- a/synaptiks/touchpad.py
++++ b/synaptiks/touchpad.py
+@@ -196,14 +196,6 @@ Whether the touchpad is off or not. Three valid values:
+ acceleration_factor = _move_speed_property(
+ 2, 'The acceleration factor of cursor movement as float')
+
+- edge_motion_always = device_property(
+- 'Synaptics Edge Motion Always', 'bool', 0,
+- '``True`` if edge motion is enabled, ``False`` otherwise.')
+-
+- fast_taps = device_property(
+- 'Synaptics Tap FastTap', 'bool', 0,
+- '``True`` if edge taps are enabled, ``False`` otherwise.')
+-
+ _tap_action_property = partial(device_property,
+ 'Synaptics Tap Action', 'byte')
+ rt_tap_action = _tap_action_property(
+@@ -291,11 +283,6 @@ generate a single scroll event.
+ circular_scrolling_distance.convert_from_property = math.degrees
+ circular_scrolling_distance.convert_to_property = math.radians
+
+- circular_touchpad = device_property(
+- 'Synaptics Circular Pad', 'bool', 0,
+- '``True``, if the touchpad is considered circular, ``False`` '
+- 'otherwise')
+-
+ @property
+ def coasting(self):
+ """
diff --git a/kde-misc/synaptiks/files/synaptiks-0.8.1-templatesfix.patch b/kde-misc/synaptiks/files/synaptiks-0.8.1-templatesfix.patch
new file mode 100644
index 000000000000..02fcee029e47
--- /dev/null
+++ b/kde-misc/synaptiks/files/synaptiks-0.8.1-templatesfix.patch
@@ -0,0 +1,48 @@
+--- /dev/null
++++ doc/_templates/issues.html
+@@ -0,0 +1,11 @@
++<h3>Issues, questions and feedback</h3>
++
++<p>
++Please join the mailing list at <a href="mailto:synaptiks@librelist.com">
++synaptiks@librelist.com</a> to ask questions or discuss
++about <strong>synaptiks</strong>. To subscribe, just send a mail to this list.
++</p>
++
++<p>You can also open an issue at the <a class="reference external"
++href="https://github.com/lunaryorn/synaptiks/issues">tracker</a> to report
++bugs or make enhancement proposals.</p>
+
+--- /dev/null
++++ doc/_templates/sidebartop.html
+@@ -0,0 +1,30 @@
++{% macro link(title, link, internal=true) -%}
++<a class="reference {{ 'internal' if internal else 'external' }}"
++ href="{{ link }}">{{ title }}</a>
++{%- endmacro %}
++
++<p>Current version: <strong>{{release}}</strong></p>
++<ul>
++ <li>{{link('Install <strong>synaptiks</strong>', pathto('install'))}}</li>
++ <li>{{link('Downloads on PyPI', 'https://pypi.python.org/pypi/synaptiks',
++ internal=false)}}</li>
++ <li>{{link('GitHub project', 'https://github.com/lunaryorn/synaptiks',
++ internal=false)}}</li>
++ <li>{{link('KDE Apps',
++ 'http://kde-apps.org/content/show.php/synaptiks?content=114270', internal=false)}}</li>
++</ul>
++
++<hr/>
++
++<ul>
++ <li>{{link('Installation instructions', pathto('install'))}}</li>
++ <li>{{link('Handbook', pathto('handbook/index'))}}
++ <ul>
++ <li>{{link('Usage', pathto('handbook/usage'))}}</li>
++ <li>{{link('Reference', pathto('handbook/reference'))}}</li>
++ </ul>
++ </li>
++ <li>{{link('Translation guide', pathto('translation_guide'))}}</li>
++ <li>{{link('API documentation', pathto('api/index'))}}</li>
++ <li>{{link('Changelog', pathto('changes'))}}</li>
++</ul>
diff --git a/kde-misc/synaptiks/metadata.xml b/kde-misc/synaptiks/metadata.xml
new file mode 100644
index 000000000000..8a9a4c524671
--- /dev/null
+++ b/kde-misc/synaptiks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="pypi">synaptiks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/kde-misc/synaptiks/synaptiks-0.8.1-r4.ebuild b/kde-misc/synaptiks/synaptiks-0.8.1-r4.ebuild
new file mode 100644
index 000000000000..ff55df7ab448
--- /dev/null
+++ b/kde-misc/synaptiks/synaptiks-0.8.1-r4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit kde4-base distutils-r1
+
+DESCRIPTION="Touchpad configuration and management tool for KDE"
+HOMEPAGE="http://synaptiks.readthedocs.org"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug doc +upower"
+
+RDEPEND="
+ >=dev-python/PyQt4-4.7[${PYTHON_USEDEP}]
+ >=dev-python/pyudev-0.8[pyqt4,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" )
+ $(add_kdeapps_dep kde-dev-scripts)
+ >=x11-drivers/xf86-input-synaptics-1.3
+ >=x11-libs/libXi-1.4
+ x11-libs/libXtst
+ upower? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )
+ )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ sys-devel/gettext
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.11-r1[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-templatesfix.patch"
+ "${FILESDIR}/${PN}-0.8.1-removedfeatures.patch"
+)
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generating documentation"
+ pushd doc > /dev/null
+ sphinx-build . _build || die
+ popd > /dev/null
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/. )
+ distutils-r1_python_install_all
+}