summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-03 19:37:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-04 13:45:35 +0200
commita19f9c8f5e44103a1c31c7d259a5f83778cdceb0 (patch)
tree3a718e76ee195dd2f9a7ce329cedc245c64bbd94 /kde-plasma/kdesu-gui
parentkde-plasma/kde-cli-tools-common: new package, add 6.1.4 (diff)
downloadgentoo-a19f9c8f5e44103a1c31c7d259a5f83778cdceb0.tar.gz
gentoo-a19f9c8f5e44103a1c31c7d259a5f83778cdceb0.tar.bz2
gentoo-a19f9c8f5e44103a1c31c7d259a5f83778cdceb0.zip
kde-plasma/kdesu-gui: new package, add 5.27.11-r1, 6.1.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kdesu-gui')
-rw-r--r--kde-plasma/kdesu-gui/Manifest2
-rw-r--r--kde-plasma/kdesu-gui/files/kdesu-gui-5.27.11-build-only-kdesu.patch87
-rw-r--r--kde-plasma/kdesu-gui/files/kdesu-gui-6.1.5-build-only-kdesu.patch72
-rw-r--r--kde-plasma/kdesu-gui/kdesu-gui-5.27.11-r1.ebuild46
-rw-r--r--kde-plasma/kdesu-gui/kdesu-gui-6.1.4.ebuild53
-rw-r--r--kde-plasma/kdesu-gui/metadata.xml12
6 files changed, 272 insertions, 0 deletions
diff --git a/kde-plasma/kdesu-gui/Manifest b/kde-plasma/kdesu-gui/Manifest
new file mode 100644
index 000000000000..f31443042e03
--- /dev/null
+++ b/kde-plasma/kdesu-gui/Manifest
@@ -0,0 +1,2 @@
+DIST kde-cli-tools-5.27.11.tar.xz 670892 BLAKE2B 56463030f1935dd722212282000f9fd5e337de7171cc2f9ec08fdae66ed681463680af33fa5ac6b21c93e9eebbb4b415a211f0e72f075521960084afa69bfdb0 SHA512 8f6bbe39df4e491a28d3c6576c58bcbf74971f54157a8cdbc3bb7d4719a31d83f38bae45402cb8f48f11bd37d907bb625f89b929b83a2bb459d7c9c836d78006
+DIST kde-cli-tools-6.1.4.tar.xz 629280 BLAKE2B accd7ffbfe0d52c4ab3bffbb2eff03f1f4ffd80b915cb9ed643fc3216d3ab23c373b29a24b273072e3ee3dddc3f72d258acee5ad9d25a8a869e16193c9413519 SHA512 8f06ef6e4eb1b070ecd2e52ca3e38c6aeb2bca3f3617dbf9a935d0a081bab71bd0d25b275ad6e19177dd8f7768b3dfd18a5b54f6074227d32e12b74c257d1689
diff --git a/kde-plasma/kdesu-gui/files/kdesu-gui-5.27.11-build-only-kdesu.patch b/kde-plasma/kdesu-gui/files/kdesu-gui-5.27.11-build-only-kdesu.patch
new file mode 100644
index 000000000000..ecca7f33a00b
--- /dev/null
+++ b/kde-plasma/kdesu-gui/files/kdesu-gui-5.27.11-build-only-kdesu.patch
@@ -0,0 +1,87 @@
+From 879f2767224d79fd9b8636b0893f6a99483c98df Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 2 Sep 2024 23:18:46 +0200
+Subject: [PATCH] Make all KF5 and Qt5 modules optional, disable all subdirs
+ except kdesu
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 42 +++++++++++++++++++++---------------------
+ 1 file changed, 21 insertions(+), 21 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fad18a81..6356d0c7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(ECMDeprecationSettings)
+
+ include(KDEGitCommitHooks)
+
+-find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
++find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG COMPONENTS
+ Widgets
+ Svg
+ DBus
+@@ -44,7 +44,7 @@ if (NOT Qt${QT_MAJOR_VERSION}Test_FOUND)
+ set(BUILD_TESTING OFF CACHE BOOL "Build the testing tree.")
+ endif()
+
+-find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
++find_package(KF5 ${KF5_MIN_VERSION} COMPONENTS
+ Config
+ DocTools
+ IconThemes
+@@ -87,31 +87,31 @@ function(install_compat_symlink executable_target)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${executable_target}5 DESTINATION ${KDE_INSTALL_FULL_BINDIR})
+ endfunction()
+
+-add_subdirectory(kcmshell)
+-add_subdirectory(keditfiletype)
+-add_subdirectory(kmimetypefinder)
+-if (QT_MAJOR_VERSION EQUAL "5")
+- add_subdirectory(ktraderclient)
+-endif()
+-add_subdirectory(kioclient)
+-add_subdirectory(ksvgtopng)
+-add_subdirectory(kdeinhibit)
+-add_subdirectory(plasma-open-settings)
+-add_subdirectory(kinfo)
+-
+-if(Qt5X11Extras_FOUND)
+- add_subdirectory(kstart)
+-endif()
++#add_subdirectory(kcmshell)
++#add_subdirectory(keditfiletype)
++#add_subdirectory(kmimetypefinder)
++#if (QT_MAJOR_VERSION EQUAL "5")
++# add_subdirectory(ktraderclient)
++#endif()
++#add_subdirectory(kioclient)
++#add_subdirectory(ksvgtopng)
++#add_subdirectory(kdeinhibit)
++#add_subdirectory(plasma-open-settings)
++#add_subdirectory(kinfo)
++
++#if(Qt5X11Extras_FOUND)
++# add_subdirectory(kstart)
++#endif()
+
+
+ if(KF5Su_FOUND)
+ add_subdirectory(kdesu)
+ endif()
+
+-if(UNIX)
+- add_subdirectory(kdeeject)
+- add_subdirectory(kbroadcastnotification)
+-endif()
++#if(UNIX)
++# add_subdirectory(kdeeject)
++# add_subdirectory(kbroadcastnotification)
++#endif()
+
+ check_include_files(sys/wait.h HAVE_SYS_WAIT_H)
+
+--
+2.46.0
+
diff --git a/kde-plasma/kdesu-gui/files/kdesu-gui-6.1.5-build-only-kdesu.patch b/kde-plasma/kdesu-gui/files/kdesu-gui-6.1.5-build-only-kdesu.patch
new file mode 100644
index 000000000000..0679d9bf8501
--- /dev/null
+++ b/kde-plasma/kdesu-gui/files/kdesu-gui-6.1.5-build-only-kdesu.patch
@@ -0,0 +1,72 @@
+From eacbe389502b4f89cb64dc24f10f3e8d2b5eb5c7 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 2 Sep 2024 23:18:46 +0200
+Subject: [PATCH] Make all KF6 and Qt6 modules optional, disable all subdirs
+ except kdesu
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dc435bca..234447e0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(ECMDeprecationSettings)
+
+ include(KDEGitCommitHooks)
+
+-find_package(Qt6 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
++find_package(Qt6 ${QT_MIN_VERSION} CONFIG COMPONENTS
+ Widgets
+ Svg
+ DBus
+@@ -44,7 +44,7 @@ if (NOT Qt6Test_FOUND)
+ set(BUILD_TESTING OFF CACHE BOOL "Build the testing tree.")
+ endif()
+
+-find_package(KF6 ${KF6_MIN_VERSION} REQUIRED COMPONENTS
++find_package(KF6 ${KF6_MIN_VERSION} COMPONENTS
+ Config
+ DocTools
+ IconThemes
+@@ -78,23 +78,23 @@ function(install_compat_symlink executable_target)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${executable_target}5 DESTINATION ${KDE_INSTALL_FULL_BINDIR})
+ endfunction()
+
+-add_subdirectory(keditfiletype)
+-add_subdirectory(kmimetypefinder)
+-add_subdirectory(kioclient)
+-add_subdirectory(ksvgtopng)
+-add_subdirectory(kdeinhibit)
+-add_subdirectory(plasma-open-settings)
+-add_subdirectory(kinfo)
+-add_subdirectory(kstart)
++#add_subdirectory(keditfiletype)
++#add_subdirectory(kmimetypefinder)
++#add_subdirectory(kioclient)
++#add_subdirectory(ksvgtopng)
++#add_subdirectory(kdeinhibit)
++#add_subdirectory(plasma-open-settings)
++#add_subdirectory(kinfo)
++#add_subdirectory(kstart)
+
+ if(KF6Su_FOUND)
+ add_subdirectory(kdesu)
+ endif()
+
+-if(UNIX)
+- add_subdirectory(kdeeject)
+- add_subdirectory(kbroadcastnotification)
+-endif()
++#if(UNIX)
++# add_subdirectory(kdeeject)
++# add_subdirectory(kbroadcastnotification)
++#endif()
+
+ check_include_files(sys/wait.h HAVE_SYS_WAIT_H)
+
+--
+2.46.0
+
diff --git a/kde-plasma/kdesu-gui/kdesu-gui-5.27.11-r1.ebuild b/kde-plasma/kdesu-gui/kdesu-gui-5.27.11-r1.ebuild
new file mode 100644
index 000000000000..cf92644003ea
--- /dev/null
+++ b/kde-plasma/kdesu-gui/kdesu-gui-5.27.11-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoff"
+ECM_TEST="false"
+KDE_ORG_NAME="kde-cli-tools"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Graphical frontend for KDE Frameworks' kdesu"
+HOMEPAGE="https://invent.kde.org/plasma/kde-cli-tools"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="0"
+KEYWORDS="~loong ~x86"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdesu-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+"
+RDEPEND="${DEPEND}
+ !<${CATEGORY}/${KDE_ORG_NAME}-6.1.4-r2:*[kdesu(+)]
+ >=${CATEGORY}/${KDE_ORG_NAME}-common-${PV}
+ sys-apps/dbus[X]
+"
+
+PATCHES=( "${FILESDIR}/${P}-build-only-kdesu.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+}
+
+src_install() {
+ ecm_src_install
+ dosym ../$(get_libdir)/libexec/kf5/kdesu /usr/bin/kdesu
+}
diff --git a/kde-plasma/kdesu-gui/kdesu-gui-6.1.4.ebuild b/kde-plasma/kdesu-gui/kdesu-gui-6.1.4.ebuild
new file mode 100644
index 000000000000..c4ba0b2f76d2
--- /dev/null
+++ b/kde-plasma/kdesu-gui/kdesu-gui-6.1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoff"
+ECM_TEST="false"
+KDE_ORG_NAME="kde-cli-tools"
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Graphical frontend for KDE Frameworks' kdesu"
+HOMEPAGE="https://invent.kde.org/plasma/kde-cli-tools"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6=[gui,widgets]
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdesu-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6[X?]
+"
+RDEPEND="${DEPEND}
+ !<${CATEGORY}/${KDE_ORG_NAME}-6.1.4-r2:*[kdesu(+)]
+ >=${CATEGORY}/${KDE_ORG_NAME}-common-${PV}
+ sys-apps/dbus[X]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-6.1.5-build-only-kdesu.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ dosym ../libexec/kf6/kdesu /usr/bin/kdesu
+}
diff --git a/kde-plasma/kdesu-gui/metadata.xml b/kde-plasma/kdesu-gui/metadata.xml
new file mode 100644
index 000000000000..7e9d56c900d5
--- /dev/null
+++ b/kde-plasma/kdesu-gui/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">plasma/kde-cli-tools</remote-id>
+ </upstream>
+</pkgmetadata>