summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-19 19:56:56 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-19 19:56:56 +0200
commit3f9d0e9c17863c7e543d1262245a4e70ef52b43b (patch)
treee1c024a49c8768a977468796610b1df903d2ace9 /kde-plasma/ksshaskpass
parentnet-analyzer/ripe-atlas-tools: Fixed dependencies for net-libs/ripe-atlas-sag... (diff)
downloadgentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.tar.gz
gentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.tar.bz2
gentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.zip
kde-plasma: Version bump KDE Plasma 5.6.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.6.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index afc4eb8d1d2d..4a80aca65f4d 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.5.5.tar.xz 20556 SHA256 8a5c48f50c4449e39dc312ca5d3dc8cec466d2fc6ad4602adf0d41ee3828fc6b SHA512 48018fe6c42e15c5338cba280f05215c6b3e0e9f015641b377f8ab0c00e6e2898e5fb9e463ac044485268378c0f0a6d6d43c4829881fbd9825c4e4dbe0dc8c1a WHIRLPOOL 5fedc473d93f5ffe66c06daff739a096306ba05e3f86c122529514a6786987d950b397f47f988a431cdb67bce2fb61a472f979bb8a7118164056ba561724148a
DIST ksshaskpass-5.6.2.tar.xz 24836 SHA256 db8d513abec7e92fb1b75abe0dbbaa06b6d365e8da2be6d10a041bb8623da125 SHA512 8fd6a987846290cb360ca72e2769245ecf292813bbce9f8ef1b243becfcb510f06e819e3251e6eda7319f0f5096f808118b53ee0b4b26015593993692ce23c94 WHIRLPOOL d1159e97153689f48ee2a5d1acc223103a797da570def55c897ba2f7de81b1ae667323066bc56ba3cb7ebfb021da2daac61785f563ae9846a8718ab400bc5d8a
+DIST ksshaskpass-5.6.3.tar.xz 24808 SHA256 feb41eaa2ba5225e69f02b1adad943f8252e8c1ed81537f98d2c5a473de5b72f SHA512 906eeb6ea267d285d1f6f9c685639ff414c723171b37994516715d9cbb6d3da172f218f15f0c0e50bab1c7eb61b6e9c26762d543a1641fb80e7e7c85d49cff7f WHIRLPOOL bfcb77549f45ea927c05c940742a1a37c77bc50a5ffa3667b0e2b8bfdf112cd9d35fd29743905014880d3d43ca6cb5380fb1c8fb73e3a37b8c6f481105ae4be5
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.6.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.6.3.ebuild
new file mode 100644
index 000000000000..ed1fdbac0d72
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/ksshaskpass
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}