summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-07 20:29:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:38 +0200
commitb3b5564327f160ed033b7c2d7781f0bb99f9dc85 (patch)
treebf8082f2f50b947e1305e878144414a8939194e3 /kde-plasma/ksysguard
parentnet-misc/vde: No more ltprune (diff)
downloadgentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.gz
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.bz2
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.zip
kde-plasma: Add KDE Plasma 5.15.5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.15.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 0ae8cd9dc540..a24ffd022aa9 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.14.5.tar.xz 501624 BLAKE2B 1d2a19d268653768affce6c746340fc1ab3e5f77cca939e6ec58f9e4285d51bffb0026f65489db54d43799df95983288d6d59d38c52aec2f63f3d668b94757db SHA512 fb04538b500f3d3dd0a3f6fa1a0adf1d3a72e2647bb48eebff8fac2c00d5f3a1de18cf4ea35bb6daa210976514bfe3d8adf8a6785d279535b0e2b4b82f25ba67
DIST ksysguard-5.15.4.tar.xz 500016 BLAKE2B ef9429bcfda7ff3d8369fc24d6e2dc93a59b8f17989016c7d983928c5201f4ab0e6ead1eb2109b3f005b161c30d80ea9c5f0d21887a3be685390f1732b933c46 SHA512 93d9404ceb8819cbe847a080a9a20835d8f68253e9772ea5f91fa9c2a8c1d20abe1427492c0788316efd6a4f973dc158d516ea6d16b4b9837fc963b4a85aead0
+DIST ksysguard-5.15.5.tar.xz 500116 BLAKE2B 1a22e419af79685e241265d392eed7502998df88168adc4292c8500a152a8d1142d56c4a34dee409b29745d8a07f889c241b3ab9ab8f09f3eec68d1ec5826c79 SHA512 ae74adac0a4b20d9ddcf9b172542a3c96de46adb66b2f6c1d4e5f97562572e365f777d1daffd82e677ca1be37e868425112f69bd6e85e51118dc557f66ab5b8e
diff --git a/kde-plasma/ksysguard/ksysguard-5.15.5.ebuild b/kde-plasma/ksysguard/ksysguard-5.15.5.ebuild
new file mode 100644
index 000000000000..dc21acd63e69
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.15.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}