summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-02 19:33:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-02 19:53:57 +0200
commit65df534564c16c1091a8b8b53467062f0223cabf (patch)
tree5ba7e828b79fb93312632b92447d87f66017b0de /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.1.2 version bump (diff)
downloadgentoo-65df534564c16c1091a8b8b53467062f0223cabf.tar.gz
gentoo-65df534564c16c1091a8b8b53467062f0223cabf.tar.bz2
gentoo-65df534564c16c1091a8b8b53467062f0223cabf.zip
kde-plasma/kwallet-pam: 6.1.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index a4d4487ba150..97587d931324 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
DIST kwallet-pam-6.1.1.tar.xz 23144 BLAKE2B 1c0abf3a62d7c259679028633ff76a297b0763953c2472c13bb7b2339c405a72220a004e9068f88016cb980679ab8bd87969c890c0bcdad51272b7c53e99d6c0 SHA512 0ec6ed20a6ca0c48ea1eafc77931a0541ec0f58be5b13914021557b32fde942515c483ef98a6b718d16bd574cb71e28d4140d9a075fb1247936d78f2762b287a
+DIST kwallet-pam-6.1.2.tar.xz 22520 BLAKE2B 0f8def4fba84ffcc949cdf5ba497810cfef9df858dd39a05733aae8f9c6bb546ebc3ff5347ecf8c1b0425bb174f0a18749d0a7eb3fb5dcf327b1b663d71243a8 SHA512 22e77644a095f940b3d9ec1eb51d04a52ec81356ed6a337065dd5ae63e762e7285ef2a29bc3c314f17bcf46021fcb67c89afdc5f1fcbf24859d724e0da674f76
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.1.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.1.2.ebuild
new file mode 100644
index 000000000000..d24f274b29d7
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}